From http://swish-e.org/archive/2015-09/13295.html
--- a/src/compress.c
+++ a/src/compress.c
@@ -995,7 +995,7 @@ void remove_worddata_longs(unsigned char *worddata,int *sz_worddata)
progerr("Internal error in remove_worddata_longs");
/* dst may be smaller than src. So move the data */
- memcpy(dst,src,data_len);
+ memmove(dst,src,data_len);
/* Increase pointers */
src += data_len;
--- a/src/headers.c
+++ a/src/headers.c
@@ -280,7 +280,7 @@ static SWISH_HEADER_VALUE fetch_single_header( IndexFILE *indexf, HEADER_MAP *he
case SWISH_NUMBER:
case SWISH_BOOL:
- value.number = *(unsigned long *) data_pointer;
+ value.number = *(unsigned int *) data_pointer;
/* $$$ Ugly hack alert! */
/* correct for removed files */
--- a/src/swishspider
+++ a/src/swishspider
@@ -27,6 +27,7 @@ use LWP::UserAgent;
use HTTP::Status;
use HTML::Parser 3.00;
use HTML::LinkExtor;
+use Encode;
if (scalar(@ARGV) != 2) {
print STDERR "Usage: $0 localpath url\n";
@@ -94,7 +95,7 @@ use HTML::LinkExtor;
# Don't allow links above the base
$URI::ABS_REMOTE_LEADING_DOTS = 1;
- $p->parse( $$content_ref );
+ $p->parse( decode_utf8 $$content_ref );
close( LINKS );
exit;
f='/guix/commit/gnu/packages/bqn.scm?id=308877be17b2c2c92d972e105e8cc6a782ab4c82'>commitdiff
|
Age | Commit message (Expand) | Author |
2024-08-31 | build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-mod......Until now users would have to cargo cult or inspect the private
%default-modules variable of (guix build-systems gnu) to discover which
modules to include when extending the used modules via the #:modules argument.
The renaming was automated via the command:
$ git grep -l %gnu-build-system-modules
| xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i
* guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to...
(%default-gnu-imported-modules): ... this.
(%default-modules): Rename to...
(%default-gnu-modules): ... this. Export.
(dist-package, gnu-build, gnu-cross-build): Adjust accordingly.
Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee
| Maxim Cournoyer |