From http://swish-e.org/archive/2015-09/13295.html
--- a/src/compress.c
+++ a/src/compress.c
@@ -995,7 +995,7 @@ void remove_worddata_longs(unsigned char *worddata,int *sz_worddata)
progerr("Internal error in remove_worddata_longs");
/* dst may be smaller than src. So move the data */
- memcpy(dst,src,data_len);
+ memmove(dst,src,data_len);
/* Increase pointers */
src += data_len;
--- a/src/headers.c
+++ a/src/headers.c
@@ -280,7 +280,7 @@ static SWISH_HEADER_VALUE fetch_single_header( IndexFILE *indexf, HEADER_MAP *he
case SWISH_NUMBER:
case SWISH_BOOL:
- value.number = *(unsigned long *) data_pointer;
+ value.number = *(unsigned int *) data_pointer;
/* $$$ Ugly hack alert! */
/* correct for removed files */
--- a/src/swishspider
+++ a/src/swishspider
@@ -27,6 +27,7 @@ use LWP::UserAgent;
use HTTP::Status;
use HTML::Parser 3.00;
use HTML::LinkExtor;
+use Encode;
if (scalar(@ARGV) != 2) {
print STDERR "Usage: $0 localpath url\n";
@@ -94,7 +95,7 @@ use HTML::LinkExtor;
# Don't allow links above the base
$URI::ABS_REMOTE_LEADING_DOTS = 1;
- $p->parse( $$content_ref );
+ $p->parse( decode_utf8 $$content_ref );
close( LINKS );
exit;
'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2024-09-08 | privilege: Add file-like->setuid-program helper....* gnu/system/privilege.scm (file-like->setuid-program): New public
procedure.
* gnu/system/setuid.scm: Re-export it for compatibility.
(file-like->setuid-program): Remove this old version.
* gnu/services/docker.scm (singularity-setuid-programs): Use it (again).
* gnu/services/desktop.scm (enlightenment-privileged-programs): Likewise.
Change-Id: I8e41144438677a15cdadb3063651dbc780715497
| Tobias Geerinckx-Rice |
2024-08-11 | privilege: Add POSIX capabilities(7) support....* gnu/system/privilege.scm (<privileged-program>): Add a field
representing the program's POSIX capabilities.
(privileged-program-capabilities): New public procedure.
* doc/guix.texi (Privileged Programs): Document it.
* gnu/build/activation.scm (activate-privileged-programs): Take a LIBCAP
package argument providing setcap(8) to apply said capabilities.
* gnu/services.scm (privileged-program->activation-gexp): Pass said
package argument where supported. Include privileged-program-capabilities
in the compatibility hack.
| Tobias Geerinckx-Rice |
2024-08-11 | system: Add (gnu system privilege)....* gnu/system/privilege.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
| Tobias Geerinckx-Rice |