Borrowed from Debian. --- swish-e-2.4.7/src/parser.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/parser.c 2013-06-11 13:53:08.196559035 +0200 @@ -1760,7 +1760,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserError(parse_data->ctxt, str); + xmlParserError(parse_data->ctxt, "%s", str); } static void warning(void *data, const char *msg, ...) @@ -1772,7 +1772,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserWarning(parse_data->ctxt, str); + xmlParserWarning(parse_data->ctxt, "%s", str); } --- swish-e-2.4.7/src/result_output.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/result_output.c 2013-06-11 13:53:38.593550825 +0200 @@ -752,7 +752,7 @@ s = (char *) emalloc(MAXWORDLEN + 1); n = strftime(s, (size_t) MAXWORDLEN, fmt, localtime(&(pv->value.v_date))); if (n && f) - fprintf(f, s); + fprintf(f, "%s", s); efree(s); } break; aryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
AgeCommit message (Expand)Author
2018-11-10gnu: wmclock: Remove custom bootstrap phase....Ricardo Wurmus
2018-11-10gnu: wmbattery: Remove custom bootstrap phase....Ricardo Wurmus
2018-02-16gnu: gnustep: Update dockapps home pages....Tobias Geerinckx-Rice
2018-02-16gnu: gnustep: Update phase style....Tobias Geerinckx-Rice
2018-02-16gnu: wmcpuload: Update to 1.1.1....Tobias Geerinckx-Rice
2018-02-16gnu: wmbattery: Update to 2.51....Tobias Geerinckx-Rice
2017-12-22gnu: windowmaker: Enable xinerama support....Kei Kebreau
2017-12-06gnu: windowmaker: Add '.desktop' file....Kei Kebreau
2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau
2017-05-08gnu: Add gnustep-make....Kei Kebreau
2017-04-24gnu: wmfire: Update source code for new GDK versions....Kei Kebreau
2017-03-14gnu: windowmaker: Use modify-phases syntax....Leo Famulari
2017-03-14gnu: windowmaker: Update to 0.95.8....Leo Famulari
2016-12-09gnu: windowmaker: Fix invocation of 'wmsetbg'....Kei Kebreau