Borrowed from Debian.
--- swish-e-2.4.7/src/parser.c 2009-04-05 03:58:32.000000000 +0200
+++ swish-e-2.4.7/src/parser.c 2013-06-11 13:53:08.196559035 +0200
@@ -1760,7 +1760,7 @@
va_start(args, msg);
vsnprintf(str, 1000, msg, args );
va_end(args);
- xmlParserError(parse_data->ctxt, str);
+ xmlParserError(parse_data->ctxt, "%s", str);
}
static void warning(void *data, const char *msg, ...)
@@ -1772,7 +1772,7 @@
va_start(args, msg);
vsnprintf(str, 1000, msg, args );
va_end(args);
- xmlParserWarning(parse_data->ctxt, str);
+ xmlParserWarning(parse_data->ctxt, "%s", str);
}
--- swish-e-2.4.7/src/result_output.c 2009-04-05 03:58:32.000000000 +0200
+++ swish-e-2.4.7/src/result_output.c 2013-06-11 13:53:38.593550825 +0200
@@ -752,7 +752,7 @@
s = (char *) emalloc(MAXWORDLEN + 1);
n = strftime(s, (size_t) MAXWORDLEN, fmt, localtime(&(pv->value.v_date)));
if (n && f)
- fprintf(f, s);
+ fprintf(f, "%s", s);
efree(s);
}
break;
id=685dd8fb1359287bb3dd4ea16c757662856b242a'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-07-07 | guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space,
which is more pleasing to the eye.
* etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option.
* etc/guix-daemon.service.in: Likewise.
* etc/init.d/guix-daemon.in: Likewise.
* etc/openrc/guix-daemon.in: Likewise.
* etc/guix-install.sh (configure_substitute_discovery): New procedure.
(sys_enable_guix_daemon): Ask the user whether automatic substitute discovery
should be enabled. Set the '--discover' argument accordingly.
(prompt_yes_no): Add a trailing space to the message.
(sys_authorize_build_farms): Remove trailing space from the message argument.
* NEWS (Distribution): Add news.
| Maxim Cournoyer |
2020-09-17 | guix-install.sh: Support OpenRC....* etc/guix-install.sh (chk_init_sys): Detect OpenRC.
(sys_enable_guix_daemon): Install & enable the Guix daemon on such
systems.
* etc/openrc/guix-daemon.in: New file.
* nix/local.mk: Add a rule for it.
(openrcservicedir, nodist_openrcservice_DATA): New variables.
(CLEANFILES, EXTRA_DIST): Add them.
* .gitignore: Ignore etc/openrc/guix-daemon.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| Morgan Smith |