Borrowed from Debian. --- swish-e-2.4.7/src/parser.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/parser.c 2013-06-11 13:53:08.196559035 +0200 @@ -1760,7 +1760,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserError(parse_data->ctxt, str); + xmlParserError(parse_data->ctxt, "%s", str); } static void warning(void *data, const char *msg, ...) @@ -1772,7 +1772,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserWarning(parse_data->ctxt, str); + xmlParserWarning(parse_data->ctxt, "%s", str); } --- swish-e-2.4.7/src/result_output.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/result_output.c 2013-06-11 13:53:38.593550825 +0200 @@ -752,7 +752,7 @@ s = (char *) emalloc(MAXWORDLEN + 1); n = strftime(s, (size_t) MAXWORDLEN, fmt, localtime(&(pv->value.v_date))); if (n && f) - fprintf(f, s); + fprintf(f, "%s", s); efree(s); } break; a href='/guix/refs/?id=3d47017b3182e781307af9dacb3ee324072c3dc2'>refslogtreecommitdiff
path: root/gnu/packages/vim.scm
AgeCommit message (Expand)Author
2023-02-12gnu: vim: Update to 9.0.1303....* gnu/packages/vim.scm (vim): Update to 9.0.1303. Efraim Flashner
2023-02-09gnu: tree-sitter: Move to its own module....* gnu/packages/text-editors.scm (tree-sitter): Move to ... * gnu/packages/tree-sitter.scm: ... here, a new module. * gnu/packages/vim.scm: Use (gnu packages tree-sitter). * gnu/packages/emacs.scm: Use (gnu packages tree-sitter). * gnu/local.mk (GNU_SYSTEM_MODULES): Register tree-sitter.scm new module. Signed-off-by: Andrew Tropin <andrew@trop.in> Pierre Langlois
2023-02-07gnu: neovim: Update to 0.8.3....* gnu/packages/vim.scm (neovim): Update to 0.8.3. Signed-off-by: Christopher Baines <mail@cbaines.net> ギャラ
2023-01-10gnu: neovim: Update to 0.8.2....* gnu/packages/vim.scm (neovim): Update to 0.8.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Luis Henrique Gomes Higino
2022-12-18gnu: vim: Update to 9.0.1073....* gnu/packages/vim.scm (vim): Update to 9.0.1073. Efraim Flashner
2022-11-27gnu: vim: Update to 9.0.0954....* gnu/packages/vim.scm (vim): Update to 9.0.0954. Efraim Flashner
2022-11-17gnu: neovim: Update to 0.8.1....* gnu/packages/vim.scm (neovim): Update to 0.8.1. Signed-off-by: Christopher Baines <mail@cbaines.net> ギャラ
2022-11-05gnu: Add python-neovim-remote....* gnu/packages/vim.scm (python-neovim-remote): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> ギャラ
2022-10-30gnu: vim: Update to 9.0.0820....* gnu/packages/vim.scm (vim): Update to 9.0.0820. Efraim Flashner
2022-10-30gnu: vim: Patch another '/bin/sh' shebang....* gnu/packages/vim.scm (vim)[arguments]: Adjust custom phase 'patch-absolute-paths to use absolute value when checking for custom cscope command. Efraim Flashner