Borrowed from Debian. --- swish-e-2.4.7/src/parser.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/parser.c 2013-06-11 13:53:08.196559035 +0200 @@ -1760,7 +1760,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserError(parse_data->ctxt, str); + xmlParserError(parse_data->ctxt, "%s", str); } static void warning(void *data, const char *msg, ...) @@ -1772,7 +1772,7 @@ va_start(args, msg); vsnprintf(str, 1000, msg, args ); va_end(args); - xmlParserWarning(parse_data->ctxt, str); + xmlParserWarning(parse_data->ctxt, "%s", str); } --- swish-e-2.4.7/src/result_output.c 2009-04-05 03:58:32.000000000 +0200 +++ swish-e-2.4.7/src/result_output.c 2013-06-11 13:53:38.593550825 +0200 @@ -752,7 +752,7 @@ s = (char *) emalloc(MAXWORDLEN + 1); n = strftime(s, (size_t) MAXWORDLEN, fmt, localtime(&(pv->value.v_date))); if (n && f) - fprintf(f, s); + fprintf(f, "%s", s); efree(s); } break; x/'>summaryrefslogtreecommitdiff
path: root/build-aux/hydra/evaluate.scm
AgeCommit message (Expand)Author
2020-03-22Remove workaround for 'time-monotonic' in Guile 2.2.2....Ludovic Courtès
2020-03-22hydra: evaluate: Use 'with-build-handler'....Ludovic Courtès
2019-01-06hydra: evaluate: Add the checkout to the store....Ludovic Courtès
2018-04-08hydra: 'guix-modular' jobs use the new 'build-self'....Ludovic Courtès
2017-11-21hydra: 'evaluate' passes an alist to the entry point....Ludovic Courtès
2017-09-28cuirass: Add 'cuirass-jobs.scm' target to compute the Cuirass jobs....Jan Nieuwenhuizen
2017-05-07maint: Add 'time-monotonic' bug workaround in build-aux/hydra/evaluate.scm....Ludovic Courtès
2016-06-21hydra: 'evaluate' now validates job alists....Ludovic Courtès
2016-04-13hydra: Add 'hydra-jobs.scm' target to compute the Hydra jobs....Ludovic Courtès