The METIS interface from Scotch may segfault if passed NULL to indicate a default parameter, so use the older calling style. --- a/SRC/get_perm_c.c 2014-05-16 23:38:30.070835316 -0500 +++ b/SRC/get_perm_c.c 2014-05-16 23:39:04.582836211 -0500 @@ -70,11 +70,13 @@ #else /* Earlier version 3.x.x */ - /* METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options, - perm, iperm);*/ + METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options, + perm, iperm); /* Latest version 4.x.x */ +#if 0 METIS_NodeND(&nm, b_colptr, b_rowind, NULL, NULL, perm, iperm); +#endif /*check_perm_dist("metis perm", n, perm);*/ #endif ect name='h' onchange='this.form.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/shepherd.scm
in lieu of a PID. * gnu/build/shepherd.scm (fork+exec-command/container): Return a PID rather than #t.
AgeCommit message (Expand)Author
2022-05-01Add (guix least-authority)....* guix/least-authority.scm: New file. * Makefile.am (MODULES): Add it. * gnu/build/shepherd.scm (default-mounts): Make public. Ludovic Courtès
2022-04-12shepherd: Add #:supplementary-groups....To support the argument introduced in Shepherd 0.9.0 when defining container-bound services. * gnu/build/shepherd.scm (e
2023-08-16Update email addresses for Juliana Sims....* .mailmap: Add an entry for Juliana. * gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/build-tools.scm, gnu/packages/scheme.scm: Update Juliana's email. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Juliana Sims
2022-01-11Update mailmap....* .mailmap: Add entry for Zheng Junjie. Leo Famulari
Ludovic Courtès
2022-04-11shepherd: 'exec-command*' has a valid default #:directory....Fixes a regression introduced in 938448bf40fc77092859352d2243e2d0c236375f where 'exec-command*' could get #:directory #f, in particular when called by 'fork+exec-command/container'. * gnu/build/shepherd.scm (exec-command*): Add default value for #:directory. Ludovic Courtès
2022-04-07shepherd: Adjust 'fork+exec-command/container' for the Shepherd 0.9....* gnu/build/shepherd.scm (exec-command*): New procedure, with code formerly... (make-forkexec-constructor/container): ... here. Use it. (fork+exec-command/container): Use 'fork+exec-command' only when CONTAINER-SUPPORT? is false or PID is the current process. Ludovic Courtès
2021-08-02build: shepherd: Use autoload to lazily bind Shepherd modules....Instead of imperative module-autoload! directives. * gnu/build/shepherd.scm: Replace module-autoload! directives by autoload arguments for define-module. Maxim Cournoyer