The METIS interface from Scotch may segfault if passed NULL to indicate a default parameter, so use the older calling style. --- a/SRC/get_perm_c.c 2014-05-16 23:38:30.070835316 -0500 +++ b/SRC/get_perm_c.c 2014-05-16 23:39:04.582836211 -0500 @@ -70,11 +70,13 @@ #else /* Earlier version 3.x.x */ - /* METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options, - perm, iperm);*/ + METIS_NodeND(&nm, b_colptr, b_rowind, &numflag, metis_options, + perm, iperm); /* Latest version 4.x.x */ +#if 0 METIS_NodeND(&nm, b_colptr, b_rowind, NULL, NULL, perm, iperm); +#endif /*check_perm_dist("metis perm", n, perm);*/ #endif hange='this.form.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/elpa.scm
AgeCommit message (Expand)Author
2023-06-09tests: Ensure 'elpa' test does not access the network....Ludovic Courtès
2023-05-31tests: Use quasiquoted 'match' patterns for package sexps....Ludovic Courtès
2023-05-31import: elpa: Updater provides input list....Ludovic Courtès
2021-12-18import: elpa: Support ‘upstream-name’ property....Xinglu Chen
2021-03-06tests: do not hard code HTTP ports...Maxime Devos
2020-12-02import: utils: 'recursive-import' accepts an optional version parameter....Martin Becze
2020-01-16import: elpa: Rewrite test to use an HTTP server instead of mocking....Ludovic Courtès