Fix required by suitesparse to build Mongoose The CMakeLists.txt of Mongoose assumes that SuiteSparse_config has been installed into the suitesparse source directory, which is not the case for us, as we are building suitesparse out-of-tree. SuiteSparse_config can instead be found in the ${CMAKE_INSTALL_PREFIX} directory. diff --git a/Mongoose/CMakeLists.txt b/Mongoose/CMakeLists.txt index 7e134ab..76fa9e2 100644 --- a/Mongoose/CMakeLists.txt +++ b/Mongoose/CMakeLists.txt @@ -148,10 +148,10 @@ set(CMAKE_CXX_STANDARD 11) #set(CMAKE_CXX_STANDARD_REQUIRED ON) # determine which SuiteSparse_config to use -if (EXISTS ${PROJECT_SOURCE_DIR}/../SuiteSparse_config) - message(STATUS "External ../SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") +if (EXISTS ${CMAKE_INSTALL_PREFIX}) + message(STATUS "External SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") set ( SUITESPARSE_CONFIG_DIR ${PROJECT_SOURCE_DIR}/../SuiteSparse_config ) - link_directories ( ${PROJECT_SOURCE_DIR}/../lib ) + link_directories ( ${CMAKE_INSTALL_PREFIX}/lib ) message ( STATUS "Note: ../SuiteSparse_config must be compiled before compiling Mongoose" ) set ( SUITESPARSE_CONFIG_LIBRARY suitesparseconfig ) else () d/accounts.scm?id=ccfafebc7d5901641328b0c5908521859b7e102e'>treecommitdiff
path: root/gnu/build/accounts.scm
he 'NIX_SUBSTITUTERS' environment variable....
AgeCommit message (Expand)Author
2019-08-28accounts: Delete duplicate entries....Ludovic Courtès
2019-06-27accounts: Use 'fsync' instead of 'fdatasync'....Ludovic Courtès
2019-06-05accounts: Call 'fdatasync' when writing databases....Ludovic Courtès
2019-06-05accounts: Close database before renaming it....Ludovic Courtès
2019-06-05activation: Lock /etc/.pwd.lock before accessing databases....Ludovic Courtès
2019-04-26accounts: Always honor the configured user account shell....Ludovic Courtès
2019-03-07Add (gnu build accounts)....Ludovic Courtès
Ludovic Courtès
2018-12-16daemon: Use unbranded phrases in comments and messages....Ludovic Courtès
2018-11-24daemon: Ignore '--keep-failed' for TCP/IP clients....Ludovic Courtès
2018-11-14daemon: Install 'authenticate' script under LIBEXECDIR/guix....Ludovic Courtès
2018-10-15daemon: Support multiplexed build output....Ludovic Courtès
2018-04-19guix-daemon: Disable garbage collection for remote connections....Roel Janssen