Fix required by suitesparse to build Mongoose The CMakeLists.txt of Mongoose assumes that SuiteSparse_config has been installed into the suitesparse source directory, which is not the case for us, as we are building suitesparse out-of-tree. SuiteSparse_config can instead be found in the ${CMAKE_INSTALL_PREFIX} directory. diff --git a/Mongoose/CMakeLists.txt b/Mongoose/CMakeLists.txt index 7e134ab..76fa9e2 100644 --- a/Mongoose/CMakeLists.txt +++ b/Mongoose/CMakeLists.txt @@ -148,10 +148,10 @@ set(CMAKE_CXX_STANDARD 11) #set(CMAKE_CXX_STANDARD_REQUIRED ON) # determine which SuiteSparse_config to use -if (EXISTS ${PROJECT_SOURCE_DIR}/../SuiteSparse_config) - message(STATUS "External ../SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") +if (EXISTS ${CMAKE_INSTALL_PREFIX}) + message(STATUS "External SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") set ( SUITESPARSE_CONFIG_DIR ${PROJECT_SOURCE_DIR}/../SuiteSparse_config ) - link_directories ( ${PROJECT_SOURCE_DIR}/../lib ) + link_directories ( ${CMAKE_INSTALL_PREFIX}/lib ) message ( STATUS "Note: ../SuiteSparse_config must be compiled before compiling Mongoose" ) set ( SUITESPARSE_CONFIG_LIBRARY suitesparseconfig ) else () ti.scm?id=fc91a71c779318f0e06884548f090f37d370a91b'>treecommitdiff
path: root/gnu/tests/ganeti.scm
AgeCommit message (Expand)Author
2023-09-08services: ganeti: Fix tests....Marius Bakke
2023-02-09system: Deprecate hosts-file....Bruno Victal
2021-12-13Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-12-12tests: Replace uses of deprecated 'static-networking-service'....Ludovic Courtès
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-10-11gnu: ganeti: Update to 3.0.1....Marius Bakke
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-06-20services: openssh: Replace 'without-password' by 'prohibit-password'....Brice Waegeneire
2020-07-19services: ganeti: Use TLS on the remote API by default....Marius Bakke
2020-07-16services: Add ganeti....Marius Bakke