Fix required by suitesparse to build Mongoose The CMakeLists.txt of Mongoose assumes that SuiteSparse_config has been installed into the suitesparse source directory, which is not the case for us, as we are building suitesparse out-of-tree. SuiteSparse_config can instead be found in the ${CMAKE_INSTALL_PREFIX} directory. diff --git a/Mongoose/CMakeLists.txt b/Mongoose/CMakeLists.txt index 7e134ab..76fa9e2 100644 --- a/Mongoose/CMakeLists.txt +++ b/Mongoose/CMakeLists.txt @@ -148,10 +148,10 @@ set(CMAKE_CXX_STANDARD 11) #set(CMAKE_CXX_STANDARD_REQUIRED ON) # determine which SuiteSparse_config to use -if (EXISTS ${PROJECT_SOURCE_DIR}/../SuiteSparse_config) - message(STATUS "External ../SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") +if (EXISTS ${CMAKE_INSTALL_PREFIX}) + message(STATUS "External SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".") set ( SUITESPARSE_CONFIG_DIR ${PROJECT_SOURCE_DIR}/../SuiteSparse_config ) - link_directories ( ${PROJECT_SOURCE_DIR}/../lib ) + link_directories ( ${CMAKE_INSTALL_PREFIX}/lib ) message ( STATUS "Note: ../SuiteSparse_config must be compiled before compiling Mongoose" ) set ( SUITESPARSE_CONFIG_LIBRARY suitesparseconfig ) else () uix/log/etc/disarchive-manifest.scm?showmsg=1'>logtreecommitdiff
path: root/etc/disarchive-manifest.scm
AgeCommit message (Collapse)Author
2023-10-08disarchive-manifest: Add one manifest entry per tarball.Ludovic Courtès
This works around a situation where ‘cuirass remote-worker’ now builds with max-jobs = 1 (Cuirass commit 980ef610989895be5ac2ba7f9d1901e5c7f22934). The effect is that all .dis.drv would be performed sequentially, on a single machine (‘cuirass remote-server’ is unable to distribute those derivations to several machines because it only “sees” the ‘disarchive-collection’ derivation). This would take a lot of time and force a rebuild of all of *.dis.drv every time because their build results would not be retrieved by the ‘remote-server’ process. * etc/disarchive-manifest.scm (disarchive-collection): Remove. <top level>: Define ‘disarchives’. Append it to the entries of the manifest.
2022-08-06disarchive-manifest: Exclude the Chromium tarball.Ludovic Courtès
* etc/disarchive-manifest.scm (disarchive-collection): Exclude "chromium-" tarballs.
2022-08-05disarchive-manifest: Filter out origins without a hash.Ludovic Courtès
* etc/disarchive-manifest.scm (disarchive-collection): Filter out origins with a phony hash.
2022-08-05disarchive-manifest: Handle tar.xz archives.Ludovic Courtès
* etc/disarchive-manifest.scm (tarball-origin?): Add ".tar.xz".
2021-10-09disarchive-manifest: Provide valid 'version' string.Ludovic Courtès
* etc/disarchive-manifest.scm <top level>: Turn 'version' field into a string.
2021-09-14etc: Add 'disarchive-manifest.scm'.Ludovic Courtès
* etc/disarchive-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it.