Fix required by suitesparse to build Mongoose
The CMakeLists.txt of Mongoose assumes that SuiteSparse_config has been
installed into the suitesparse source directory, which is not the case
for us, as we are building suitesparse out-of-tree.
SuiteSparse_config can instead be found in the ${CMAKE_INSTALL_PREFIX}
directory.
diff --git a/Mongoose/CMakeLists.txt b/Mongoose/CMakeLists.txt
index 7e134ab..76fa9e2 100644
--- a/Mongoose/CMakeLists.txt
+++ b/Mongoose/CMakeLists.txt
@@ -148,10 +148,10 @@ set(CMAKE_CXX_STANDARD 11)
#set(CMAKE_CXX_STANDARD_REQUIRED ON)
# determine which SuiteSparse_config to use
-if (EXISTS ${PROJECT_SOURCE_DIR}/../SuiteSparse_config)
- message(STATUS "External ../SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".")
+if (EXISTS ${CMAKE_INSTALL_PREFIX})
+ message(STATUS "External SuiteSparse_config" ${BoldBlue} " found" ${ColourReset} ".")
set ( SUITESPARSE_CONFIG_DIR ${PROJECT_SOURCE_DIR}/../SuiteSparse_config )
- link_directories ( ${PROJECT_SOURCE_DIR}/../lib )
+ link_directories ( ${CMAKE_INSTALL_PREFIX}/lib )
message ( STATUS "Note: ../SuiteSparse_config must be compiled before compiling Mongoose" )
set ( SUITESPARSE_CONFIG_LIBRARY suitesparseconfig )
else ()
s/gawk.scm?id=357436b8404f1a08171e41ac14ff7d16ebc3d79f'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: cppawk: Fix build....* gnu/packages/gawk.scm (cppawk)[arguments]: Don't refer to nonexistent
'build' phase. Fix "/bin/sh" and "/usr/bin/awk" paths in test fails.
Change-Id: Id86a78378558592c41f19f15e4c5e4890f995a6c
| 宋文武 |
2024-08-31 | gnu: gawk: Update to 5.3.0....* gnu/packages/gawk.scm (gawk): Update to 5.3.0.
Change-Id: Ib1e64d3ed08eb6564ed1ce32ec31ad6492886c92
| Ludovic Courtès |
2024-08-31 | gnu: commencement: Remove ‘glibc-utf8-locales’ from ‘%final-inputs’....* gnu/packages/commencement.scm (%boot5-inputs): Make an alias for
‘%boot4-inputs’.
(with-boot5): Turn into an alias for ‘with-boot4’.
(%final-inputs): Override ‘native-inputs’ of GAWK. Remove "locales"
entry.
(canonical-package): Add “glibc-utf8-locales” entry.
* gnu/packages/base.scm (libc-utf8-locales-for-target): Use
‘canonical-package’.
* gnu/packages/gawk.scm (gawk)[native-inputs]: New field.
* gnu/packages/texinfo.scm (texinfo)[native-inputs]: Add
‘libc-utf8-locales-for-target’.
Change-Id: I2283ffc6c6000c98ad2db89c04d581e050667c94
| Ludovic Courtès |
2024-08-31 | gnu: gawk: Update to 5.2.2....* gnu/packages/gawk.scm (gawk): Update to 5.2.2.
| Efraim Flashner |