Prevent strace's "readlink" and "readlinkat" tests from failing due to the additional system call made by glibc with the patch "glibc-dl-cache.patch" applied (introduced in commit 52564e9). These changes cause strace to report during these tests only system calls on files contained in the test directory, effectively filtering out the additional readlink/readlinkat call on "/proc/self/exe" and allowing the tests to complete as normal. diff --git a/tests/gen_tests.in b/tests/gen_tests.in index 8b4e2e9..cc3ca63 100644 --- a/tests/gen_tests.in +++ b/tests/gen_tests.in @@ -623,8 +623,8 @@ quotactl-xfs-v -v -e trace=quotactl read-write -a15 -eread=0,5 -ewrite=1,4 -e trace=read,write -P read-write-tmpfile -P /dev/zero -P /dev/null readahead -a1 readdir -a16 -readlink -xx -readlinkat -xx +readlink -xx --trace-path=test.readlink.link +readlinkat -xx --trace-path=test.readlinkat.link reboot -s 256 recv-MSG_TRUNC -a26 -e trace=recv recvfrom -a35 diff --git a/tests/readlink.gen.test b/tests/readlink.gen.test index 4263234..418691b 100755 --- a/tests/readlink.gen.test +++ b/tests/readlink.gen.test @@ -1,4 +1,4 @@ #!/bin/sh -efu -# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlink -xx ); do not edit. +# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlink -xx --trace-path=test.readlink.link); do not edit. . "${srcdir=.}/init.sh" -run_strace_match_diff -xx +run_strace_match_diff -xx --trace-path=test.readlink.link diff --git a/tests/readlinkat.gen.test b/tests/readlinkat.gen.test index d7de993..a48d590 100755 --- a/tests/readlinkat.gen.test +++ b/tests/readlinkat.gen.test @@ -1,4 +1,4 @@ #!/bin/sh -efu -# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlinkat -xx ); do not edit. +# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlinkat -xx --trace-path=test.readlinkat.link); do not edit. . "${srcdir=.}/init.sh" -run_strace_match_diff -xx +run_strace_match_diff -xx --trace-path=test.readlinkat.link root/gnu/tests/web.scm
AgeCommit message (Expand)Author
2019-05-31services: Add patchwork....Christopher Baines
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-09-28tests: Add missing copyright statement....Marius Bakke
2018-09-26services: Add Varnish service....Marius Bakke
2018-09-10services: tailon: Move to (gnu services web)....Ludovic Courtès
2018-06-13tests: Honor the return value of 'start-service'....Clément Lassieur
2018-06-01services: Add hpcguix-web....Rouby Pierre-Antoine
2018-01-17gnu: services: web: Add service for httpd....Christopher Baines
2018-01-17gnu: tests: web: Generalise the nginx test....Christopher Baines
2017-12-19tests: Adjust php-fpm test to new nginx API....Ludovic Courtès
2017-12-18services: nginx: Replace 'http-port' and 'https-port' with 'listen'....Clément Lassieur
2017-12-12gnu: services: Add php-fpm....nee
2017-12-11services: web: Remove default certificate and key files for nginx....Christopher Baines
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-04-15tests: Remove unused import (gnu system grub)....Danny Milosavljevic
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès
2017-01-19tests: Add 'nginx-service-type' test....Ludovic Courtès