Prevent strace's "readlink" and "readlinkat" tests from failing due to the additional system call made by glibc with the patch "glibc-dl-cache.patch" applied (introduced in commit 52564e9). These changes cause strace to report during these tests only system calls on files contained in the test directory, effectively filtering out the additional readlink/readlinkat call on "/proc/self/exe" and allowing the tests to complete as normal. diff --git a/tests/gen_tests.in b/tests/gen_tests.in index 8b4e2e9..cc3ca63 100644 --- a/tests/gen_tests.in +++ b/tests/gen_tests.in @@ -623,8 +623,8 @@ quotactl-xfs-v -v -e trace=quotactl read-write -a15 -eread=0,5 -ewrite=1,4 -e trace=read,write -P read-write-tmpfile -P /dev/zero -P /dev/null readahead -a1 readdir -a16 -readlink -xx -readlinkat -xx +readlink -xx --trace-path=test.readlink.link +readlinkat -xx --trace-path=test.readlinkat.link reboot -s 256 recv-MSG_TRUNC -a26 -e trace=recv recvfrom -a35 diff --git a/tests/readlink.gen.test b/tests/readlink.gen.test index 4263234..418691b 100755 --- a/tests/readlink.gen.test +++ b/tests/readlink.gen.test @@ -1,4 +1,4 @@ #!/bin/sh -efu -# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlink -xx ); do not edit. +# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlink -xx --trace-path=test.readlink.link); do not edit. . "${srcdir=.}/init.sh" -run_strace_match_diff -xx +run_strace_match_diff -xx --trace-path=test.readlink.link diff --git a/tests/readlinkat.gen.test b/tests/readlinkat.gen.test index d7de993..a48d590 100755 --- a/tests/readlinkat.gen.test +++ b/tests/readlinkat.gen.test @@ -1,4 +1,4 @@ #!/bin/sh -efu -# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlinkat -xx ); do not edit. +# Generated by ./tests/gen_tests.sh from ./tests/gen_tests.in (readlinkat -xx --trace-path=test.readlinkat.link); do not edit. . "${srcdir=.}/init.sh" -run_strace_match_diff -xx +run_strace_match_diff -xx --trace-path=test.readlinkat.link name='id' value='4442a5db773f79e05c37e014c63b4298e7de666b'/>
context: | |
space: | |
mode: | |
author | Marius Bakke <marius@gnu.org> | 2022-07-13 23:34:58 +0200 |
---|---|---|
committer | Marius Bakke <marius@gnu.org> | 2022-07-13 23:34:58 +0200 |
commit | 4442a5db773f79e05c37e014c63b4298e7de666b (patch) | |
tree | 880a6fdce7b288eaa506828b9b500191ca60ce24 | |
parent | 5b48591176a08bddfd0147bd854785fb4f6a62ba (diff) | |
parent | b160795a0b65d67ff5d64447f1b97c2f009517a0 (diff) | |
download | guix-4442a5db773f79e05c37e014c63b4298e7de666b.tar.gz guix-4442a5db773f79e05c37e014c63b4298e7de666b.zip |