Do not attempt to create $localstatedir and $sysconfdir (i.e., /var and /etc)
upon "make install".
diff --git a/Makefile.am b/Makefile.am
index e780e8a14..afd2b0a49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,7 +84,7 @@ pkgconfigdir = $(libdir)/pkgconfig
krb5rcachedir = @krb5rcachedir@
sudolibdir = @sudolibpath@
polkitdir = @polkitdir@
-pamconfdir = $(sysconfdir)/pam.d
+pamconfdir = $(prefix)/etc/pam.d
systemtap_tapdir = @tapset_dir@
sssdkcmdatadir = $(datadir)/sssd-kcm
deskprofilepath = $(sss_statedir)/deskprofile
@@ -5378,7 +5378,6 @@ installsssddirs::
$(DESTDIR)$(bindir) \
$(DESTDIR)$(sbindir) \
$(DESTDIR)$(mandir) \
- $(DESTDIR)$(pidpath) \
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbuspolicydir) \
@@ -5388,24 +5387,12 @@ installsssddirs::
$(DESTDIR)$(sssddatadir) \
$(DESTDIR)$(sudolibdir) \
$(DESTDIR)$(autofslibdir) \
- $(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(krb5snippetsdir) \
- $(SSSD_USER_DIRS) \
$(NULL);
if SSSD_USER
-chown $(SSSD_USER):$(SSSD_USER) $(SSSD_USER_DIRS)
-chown $(SSSD_USER) $(DESTDIR)$(pipepath)/private
endif
- $(INSTALL) -d -m 0700 $(DESTDIR)$(dbpath) $(DESTDIR)$(logpath) \
- $(DESTDIR)$(keytabdir) \
- $(NULL)
- $(INSTALL) -d -m 0750 $(DESTDIR)$(pipepath)/private
- $(INSTALL) -d -m 0755 $(DESTDIR)$(mcpath) $(DESTDIR)$(pipepath) \
- $(DESTDIR)$(pubconfpath) \
- $(DESTDIR)$(pubconfpath)/krb5.include.d $(DESTDIR)$(gpocachepath)
- $(INSTALL) -d -m 0711 $(DESTDIR)$(sssdconfdir) \
- $(DESTDIR)$(sssdconfdir)/conf.d \
- $(DESTDIR)$(sssdconfdir)/pki
if HAVE_DOXYGEN
docs:
@@ -5523,7 +5510,6 @@ if BUILD_SAMBA
endif
if BUILD_KCM
$(MKDIR_P) $(DESTDIR)/$(sssdkcmdatadir)
- $(MKDIR_P) $(DESTDIR)$(secdbpath)
endif
uninstall-hook:
nge'>range
Age Commit message (Expand ) Author
2024-08-31 gnu: po4a: Update to 0.73. ...* gnu/packages/gettext.scm (po4a): Update to 0.73.
[native-inputs]: Update docbook-xml to 4.5.
[source]: Remove the patch since it is merged in version 0.70.
* gnu/local.mk, gnu/packages/patches/po4a-partial-texinfo-menu-fix.patch:
Same as above.
Change-Id: Iefe13931415409e30d8da982dccc6e1adf1b2984
Signed-off-by: Christopher Baines <mail@cbaines.net>
gemmaro
2024-08-31 gnu: po4a: Enable SGML format. ...* gnu/packages/gettext.scm (po4a): Enable SGML format.
[arguments]<phases>: Remove disable-failing-tests phase.
[native-inputs]: Add docbook-sgml-4.1. Remove libxml2.
[inputs]: Add opensp.
Modified-by: Bruno Victal <mirai@makinata.eu>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
gemmaro
2024-05-13 gnu: Add po4a-minimal. ...The main reason is to avoid the texlive-updmap.cfg input indirectly pulling in
nss, which has a very time consuming testsuite.
* gnu/packages/gettext.scm (po4a-minimal): New variable.
Change-Id: If8d46a18a02e57d5427852e8e122de01f970ded4
Christopher Baines