Fixes a potential buffer overflow in the protocol handling. https://bugzilla.redhat.com/show_bug.cgi?id=1399566 https://access.redhat.com/security/cve/CVE-2016-9578 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9578 https://security-tracker.debian.org/tracker/CVE-2016-9578 Patch copied from upstream source repository: https://cgit.freedesktop.org/spice/spice/commit/?h=0.12&id=f66dc643635518e53dfbe5262f814a64eec54e4a From f66dc643635518e53dfbe5262f814a64eec54e4a Mon Sep 17 00:00:00 2001 From: Frediano Ziglio Date: Tue, 13 Dec 2016 14:40:10 +0000 Subject: Prevent integer overflows in capability checks diff --git a/server/reds.c b/server/reds.c index 86a33d5..9150454 100644 --- a/server/reds.c +++ b/server/reds.c @@ -2110,6 +2110,14 @@ static void reds_handle_read_link_done(void *opaque) link_mess->num_channel_caps = GUINT32_FROM_LE(link_mess->num_channel_caps); link_mess->num_common_caps = GUINT32_FROM_LE(link_mess->num_common_caps); + /* Prevent DoS. Currently we defined only 13 capabilities, + * I expect 1024 to be valid for quite a lot time */ + if (link_mess->num_channel_caps > 1024 || link_mess->num_common_caps > 1024) { + reds_send_link_error(link, SPICE_LINK_ERR_INVALID_DATA); + reds_link_free(link); + return; + } + num_caps = link_mess->num_common_caps + link_mess->num_channel_caps; caps = (uint32_t *)((uint8_t *)link_mess + link_mess->caps_offset); -- cgit v0.10.2 ht' method='get' action='/guix/log/po/packages'>
path: root/po/packages
AgeCommit message (Expand)Author
2020-04-14nls: Update.Ludovic Courtès
2020-04-12nls: Update.Ludovic Courtès
2020-03-23nls: Update.Ludovic Courtès
2019-05-13nls: Update 'fr' translation.Julien Lepiller
2019-05-03nls: Update da translations.Ludovic Courtès
2019-05-01nls: Update translations for de and fr.Ludovic Courtès
2019-04-25nls: Update 'es' translation.Julien Lepiller
2019-04-25nls: Update 'fr' translation.Julien Lepiller
2019-04-13nls: Update 'fr' translation.Julien Lepiller
2019-02-13nls: Update 'de' translation.Julien Lepiller
2019-02-13nls: Update 'da' translation.Julien Lepiller
2018-12-02nls: Update 'fr' translation.Julien Lepiller
2018-06-23nls: Update 'fr' translation.Julien Lepiller
2018-06-18nls: Update 'da' translation.Ludovic Courtès
2018-04-19nls: Update 'es' translation.Ludovic Courtès
2018-04-11nls: Add Spanish translation.Ludovic Courtès