Exit after the user's session has finished. This works around slim's broken
PAM session handling (see
http://developer.berlios.de/bugs/?func=detailbug&bug_id=19102&group_id=2663).
Patch by Eelco Dolstra, from Nixpkgs.
--- slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
+++ slim-1.3.6/app.cpp 2013-10-15 13:00:10.141210784 +0200
@@ -816,7 +822,7 @@
StopServer();
RemoveLock();
while (waitpid(-1, NULL, WNOHANG) > 0); /* Collects all dead childrens */
- Run();
+ exit(OK_EXIT);
}
void App::KillAllClients(Bool top) {
/'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-08-13 | gnu: noweb: Update to 2.13....* gnu/packages/noweb.scm (noweb): Update to 2.13.
| Tobias Geerinckx-Rice |
2023-08-13 | gnu: noweb: Use G-expressions....* gnu/packages/noweb.scm (noweb)[arguments]:
Rewrite as G-expressions. Don't explicitly return #t from phases.
| Tobias Geerinckx-Rice |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |