Exit after the user's session has finished. This works around slim's broken
PAM session handling (see
http://developer.berlios.de/bugs/?func=detailbug&bug_id=19102&group_id=2663).
Patch by Eelco Dolstra, from Nixpkgs.
--- slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
+++ slim-1.3.6/app.cpp 2013-10-15 13:00:10.141210784 +0200
@@ -816,7 +822,7 @@
StopServer();
RemoveLock();
while (waitpid(-1, NULL, WNOHANG) > 0); /* Collects all dead childrens */
- Run();
+ exit(OK_EXIT);
}
void App::KillAllClients(Bool top) {
ef='/'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-04-13 | gnu: autogen: Disable parallel tests....* gnu/packages/autogen.scm (autogen)[arguments]: Add #:parallel-tests?.
| Marius Bakke |
2019-02-24 | gnu: autogen: Update to 5.18.16....* gnu/packages/autogen.scm (autogen): Update to 5.18.16.
[inputs]: Update to guile-2.2.
[arguments]: Add ‘--disable-dependency-tracking’ to #:configure-flags.
Re-indent.
| Tobias Geerinckx-Rice |
2018-08-09 | gnu: autogen: Update to 5.18.14....* gnu/packages/autogen.scm (autogen): Update to 5.18.14.
[inputs]: Move perl from native-inputs to here...
[native-inputs]: ...and which from inputs to here.
[arguments]: Remove unnecessary ‘/usr/bin/tr’ substitution.
| Tobias Geerinckx-Rice |