Exit after the user's session has finished. This works around slim's broken
PAM session handling (see
http://developer.berlios.de/bugs/?func=detailbug&bug_id=19102&group_id=2663).
Patch by Eelco Dolstra, from Nixpkgs.
--- slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
+++ slim-1.3.6/app.cpp 2013-10-15 13:00:10.141210784 +0200
@@ -816,7 +822,7 @@
StopServer();
RemoveLock();
while (waitpid(-1, NULL, WNOHANG) > 0); /* Collects all dead childrens */
- Run();
+ exit(OK_EXIT);
}
void App::KillAllClients(Bool top) {
>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-07-31 | gnu: qttools: Rename to qttools-5....Automated with:
git grep -l qttools | xargs sed 's/\bqttools\b/\0-5/g' -i
git checkout NEWS
| Maxim Cournoyer |
2022-05-31 | gnu: pdf2djvu: Disable tests to avoid Python 2 dependencies....* gnu/packages/djvu.scm (pdf2djvu)[tests]: Set to #f.
[test-target]: Delete argument.
[native-inputs]: Use new style. Delete python-2 and python2-nose.
[inputs]: Use new style.
| Maxim Cournoyer |
2022-05-31 | gnu: didjvu: Switch to a Python 3 compatible fork....* gnu/packages/djvu.scm (didjvu)[source]: Switch to a Python 3 compatible
fork.
[native-inputs, inputs]: Move below arguments field. Use new style. Replace
the Python 2 inputs by their Python 3 equivalents.
| Maxim Cournoyer |
2022-05-31 | gnu: Remove djvusmooth....* gnu/packages/djvu.scm (djvusmooth): Delete variable.
| Maxim Cournoyer |
2022-05-31 | gnu: ocrodjvu: Use a Python 3 compatible fork....* gnu/packages/djvu.scm (ocrodjvu)[source]: Update URL to Python 3 fork.
[inputs]: Use new style. Remove python2-subprocess32. Replace all other
Python 2 inputs by their Python 3 equivalent. Add python-future and
python-regex.
[arguments]: Use gexps, and adjust accordingly, using this-package-input and
search-input-file.
| Maxim Cournoyer |