Display configurable login message after successful authentication. Patch by E. Bavier --- slim-1.3.6/panel.cpp.orig 1969-12-31 18:00:00.000000000 -0600 +++ slim-1.3.6/panel.cpp 2016-10-17 17:00:07.259649063 -0500 @@ -260,6 +260,7 @@ void Panel::ClosePanel() { XUngrabKeyboard(Dpy, CurrentTime); + XClearWindow(Dpy, Root); XUnmapWindow(Dpy, Win); XDestroyWindow(Dpy, Win); XFlush(Dpy); --- slim-1.3.6/cfg.cpp.orig 2016-10-17 17:08:06.767666139 -0500 +++ slim-1.3.6/cfg.cpp 2016-10-17 17:06:53.115663516 -0500 @@ -52,6 +52,7 @@ options.insert(option("lockfile","/var/run/slim.lock")); options.insert(option("logfile","/var/log/slim.log")); options.insert(option("authfile","/var/run/slim.auth")); + options.insert(option("login_msg","Logging in...")); options.insert(option("shutdown_msg","The system is halting...")); options.insert(option("reboot_msg","The system is rebooting...")); options.insert(option("sessiondir","")); --- slim-1.3.6/app.cpp.orig 2016-10-17 17:08:41.731667384 -0500 +++ slim-1.3.6/app.cpp 2016-10-17 17:07:48.415665486 -0500 @@ -520,6 +520,8 @@ struct passwd *pw; pid_t pid; + LoginPanel->Message((char*)cfg->getOption("login_msg").c_str()); + #ifdef USE_PAM try{ pam.open_session(); tree/doc/htmlxref.cnf?id=02de4b1da184eb087f6eee794842ceb795cf38fe'>treecommitdiff
path: root/doc/htmlxref.cnf
AgeCommit message (Expand)Author
2020-01-12doc: Update htmlxref.cnf....Ludovic Courtès
2019-05-04doc: Update htmlxref.cnf....Ludovic Courtès
2018-07-05doc: Update URL of the Emacs-Guix manual....Ludovic Courtès
2018-07-05doc: Mention translations of the manual....Ludovic Courtès
2017-05-30doc: htmlxref: Fix link to Emacs-Guix manual....Alex Kost
2017-05-04doc: Add references to Emacs-Guix manual....Alex Kost
2016-12-29Remove Emacs interface....Alex Kost
2016-08-03doc: Update Texinfo HTML cross-reference file.....Ludovic Courtès
2016-03-30doc: Fix URL of gnutls-guile one-page-per-node manual....Ludovic Courtès
2016-02-21doc: Add Texinfo HTML cross-reference file....Ludovic Courtès