Allow the configuration file and theme directory to be specified at run time. Patch by Eelco Dolstra, from Nixpkgs. --- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200 +++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200 @@ -200,7 +200,9 @@ /* Read configuration and theme */ cfg = new Cfg; - cfg->readConf(CFGFILE); + char *cfgfile = getenv("SLIM_CFGFILE"); + if (!cfgfile) cfgfile = CFGFILE; + cfg->readConf(cfgfile); string themebase = ""; string themefile = ""; string themedir = ""; @@ -208,7 +210,9 @@ if (testing) { themeName = testtheme; } else { - themebase = string(THEMESDIR) + "/"; + char *themesdir = getenv("SLIM_THEMESDIR"); + if (!themesdir) themesdir = THEMESDIR; + themebase = string(themesdir) + "/"; themeName = cfg->getOption("current_theme"); string::size_type pos; if ((pos = themeName.find(",")) != string::npos) { type='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/bootloader.scm
93497eb2ee3127270dea12be103f1bc2'>maint: Give command to install the pre-push hook....
AgeCommit message (Expand)Author
2019-03-16booloader: Add 'invoke/quiet'....Ludovic Courtès
2017-12-15bootloader: Factorize write-file-on-device....Mathieu Othacehe
Ludovic Courtès
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'....Clément Lassieur
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'....Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....Mathieu Lirzin
2017-01-04doc: Add a Git hook that verifies signatures before pushing....Leo Famulari
2016-07-24doc: Explain how to set up Git for signing....Ludovic Courtès
2016-07-14doc: Mention commit signatures in HACKING....Leo Famulari