Allow the configuration file and theme directory to be specified at run time.
Patch by Eelco Dolstra, from Nixpkgs.
--- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200
+++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
@@ -200,7 +200,9 @@
/* Read configuration and theme */
cfg = new Cfg;
- cfg->readConf(CFGFILE);
+ char *cfgfile = getenv("SLIM_CFGFILE");
+ if (!cfgfile) cfgfile = CFGFILE;
+ cfg->readConf(cfgfile);
string themebase = "";
string themefile = "";
string themedir = "";
@@ -208,7 +210,9 @@
if (testing) {
themeName = testtheme;
} else {
- themebase = string(THEMESDIR) + "/";
+ char *themesdir = getenv("SLIM_THEMESDIR");
+ if (!themesdir) themesdir = THEMESDIR;
+ themebase = string(themesdir) + "/";
themeName = cfg->getOption("current_theme");
string::size_type pos;
if ((pos = themeName.find(",")) != string::npos) {
bmit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2017-04-18 | Merge branch 'master' into staging | Marius Bakke |
2017-04-17 | gnu: gtk+: Update to 3.22.12....* gnu/packages/gtk.scm (gtk+): Update 3.22.12.
| Kei Kebreau |
2017-04-17 | gnu: Fix typos in descriptions....* gnu/packages/admin.scm (di)[description]: Likewise.
* gnu/packages/bioinformatics.scm (r-annotate)[description]: Likewise.
* gnu/packages/datastructures.scm (sparsehash)[description]: Likewise.
* gnu/packages/dns.scm (knot)[description]: Likewise.
* gnu/packages/emacs.scm (emacs-idle-highlight)[synopsis, description]:
Likewise.
* gnu/packages/gnome.scm (libpeas)[description]: Likewise.
* gnu/packages/gtk.scm (python2-pygtk)[description]: Likewise.
* gnu/packages/kde-frameworks.scm (kactivities)[description]: Fix typo.
* gnu/packages/libevent.scm (perl-anyevent)[description]: Likewise.
* gnu/packages/machine-learning.scm (ghmm)[description]: Likewise.
* gnu/packages/mail.scm (mlmmj)[description]: Likewise.
* gnu/packages/maths.scm (vc)[description]: Likewise.
* gnu/packages/music.scm (gx-super-fuzz-lv2)[description]: Likewise.
* gnu/packages/networking.scm (nload)[description]: Likewise.
* gnu/packages/python.scm (python-execnet)[description]: Likewise.
* gnu/packages/terminals.scm (tilda)[description]: Likewise.
* gnu/packages/python.scm (python-execnet, python-tables)
(python2-coverage-test-runner, python2-rope)[description]: Likewise.
| Tobias Geerinckx-Rice |
2017-04-15 | gnu: Add graphene....* gnu/packages/gtk.scm (graphene): New variable.
| Roel Janssen |
2017-04-15 | gnu: gdk-pixbuf: Update to 2.36.6....* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.36.6.
| Kei Kebreau |
2017-04-06 | gnu: xorg-server@1.19.2: Update to 1.19.3....This is to adjust for the inputs and arguments change of xorg-server proper.
* gnu/packages/xorg.scm (xorg-server-1.19.2): Rename to ...
(xorg-server-1.19.3): ... this. Update version and origin.
* gnu/packages/gtk.scm (gtk+)[native-inputs]: Adjust accordingly.
[arguments]<#:disallowed-references>: Likewise.
| Marius Bakke |
2017-03-30 | Merge branch 'master' into core-updates...Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698.
| Marius Bakke |
2017-03-30 | gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....All HTTP gnu.org (and supported subdomain) HOME-PAGEs changed to HTTPS.
| Tobias Geerinckx-Rice |