Allow the configuration file and theme directory to be specified at run time.
Patch by Eelco Dolstra, from Nixpkgs.
--- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200
+++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
@@ -200,7 +200,9 @@
/* Read configuration and theme */
cfg = new Cfg;
- cfg->readConf(CFGFILE);
+ char *cfgfile = getenv("SLIM_CFGFILE");
+ if (!cfgfile) cfgfile = CFGFILE;
+ cfg->readConf(cfgfile);
string themebase = "";
string themefile = "";
string themedir = "";
@@ -208,7 +210,9 @@
if (testing) {
themeName = testtheme;
} else {
- themebase = string(THEMESDIR) + "/";
+ char *themesdir = getenv("SLIM_THEMESDIR");
+ if (!themesdir) themesdir = THEMESDIR;
+ themebase = string(themesdir) + "/";
themeName = cfg->getOption("current_theme");
string::size_type pos;
if ((pos = themeName.find(",")) != string::npos) {
put type='submit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: moreutils: Add 'bash' input for 'wrap-program'....It is required for cross-compilation.
* gnu/packages/moreutils.scm (moreutils)[inputs]: Add 'bash-minimal'.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I3f0d8ec4f7f6c99a5c759abe2f438ccbbb5c913c
| Maxime Devos |
2024-08-31 | gnu: docbook: Remove leftovers....docbook-xsl patches are probably remnants from
1f7d94597f1e78776f854eeca46c03a3aded8466.
* gnu/packages/docbook.scm: Remove unused import.
* gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: Remove.
* gnu/packages/patches/docbook-xsl-support-old-url.patch: Ditto.
* gnu/local.mk: Unregister it.
* gnu/packages/moreutils.scm (moreutils)[native-inputs]: Drop obsolete
comment.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Bruno Victal |
2024-04-26 | gnu: moreutils: Update to 0.69....* gnu/packages/moreutils.scm (moreutils): Update to 0.69.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| fanquake |
2023-11-19 | gnu: moreutils: Update to 0.68....* gnu/packages/moreutils.scm (moreutils): Update to 0.68.
Change-Id: Ie8320c18eaef1b481918894c5baaedc4144b0d19
| Tobias Geerinckx-Rice |