Allow the configuration file and theme directory to be specified at run time. Patch by Eelco Dolstra, from Nixpkgs. --- slim-1.3.6/app.cpp 2013-10-02 00:38:05.000000000 +0200 +++ slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200 @@ -200,7 +200,9 @@ /* Read configuration and theme */ cfg = new Cfg; - cfg->readConf(CFGFILE); + char *cfgfile = getenv("SLIM_CFGFILE"); + if (!cfgfile) cfgfile = CFGFILE; + cfg->readConf(cfgfile); string themebase = ""; string themefile = ""; string themedir = ""; @@ -208,7 +210,9 @@ if (testing) { themeName = testtheme; } else { - themebase = string(THEMESDIR) + "/"; + char *themesdir = getenv("SLIM_THEMESDIR"); + if (!themesdir) themesdir = THEMESDIR; + themebase = string(themesdir) + "/"; themeName = cfg->getOption("current_theme"); string::size_type pos; if ((pos = themeName.find(",")) != string::npos) { put type='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/git-authenticate.scm
AgeCommit message (Expand)Author
2023-09-26tests: Assume ‘git’ is always available....Ludovic Courtès
2022-02-14git-authenticate: Ensure the target is a descendant of the introductory commit....Ludovic Courtès
2022-02-14git-authenticate: Test introductory commit signature verification....Ludovic Courtès
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....Attila Lendvai
2020-06-28tests: Allow 'tests/git-authenticate.scm' to run when git/gpg is missing....Ludovic Courtès
2020-06-20tests: Skip tests that requires gpg when gpg is unavailable....Ludovic Courtès
2020-06-16tests: Move OpenPGP helpers to (guix tests gnupg)....Ludovic Courtès
2020-06-12git-authenticate: Disallow SHA1 (and MD5) signatures....Ludovic Courtès
2020-06-07git-authenticate: Prevent removal of '.guix-authorizations'....Ludovic Courtès
2020-06-05git-authenticate: Add tests....Ludovic Courtès