Fix CVE-2018-1000097:
https://security-tracker.debian.org/tracker/CVE-2018-1000097
https://nvd.nist.gov/vuln/detail/CVE-2018-1000097
Patch taken from upstream bug report:
https://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00005.html
diff --git a/src/unshar.c b/src/unshar.c
index 80bc3a9..0fc3773 100644
--- a/src/unshar.c
+++ b/src/unshar.c
@@ -240,7 +240,7 @@ find_archive (char const * name, FILE * file, off_t start)
off_t position = ftello (file);
/* Read next line, fail if no more and no previous process. */
- if (!fgets (rw_buffer, BUFSIZ, file))
+ if (!fgets (rw_buffer, rw_base_size, file))
{
if (!start)
error (0, 0, _("Found no shell commands in %s"), name);
lected'>koszko
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2019-11-09 | doc: Mention value /var to localstatedir option....* README (Installing Guix from Guix): Mention value /var to localstatedir option.
* doc/contributing.texi (Building from Git): Likewise.
* doc/guix.texi (Requirements): Likewise.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| zimoun |
2019-09-04 | doc: Update 'README'....* README: Update intro a bit.
(Installing Guix as non-root): Remove as it's largely outdated.
(Contact): Update.
| Ludovic Courtès |