Fix CVE-2018-1000097:
https://security-tracker.debian.org/tracker/CVE-2018-1000097
https://nvd.nist.gov/vuln/detail/CVE-2018-1000097
Patch taken from upstream bug report:
https://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00005.html
diff --git a/src/unshar.c b/src/unshar.c
index 80bc3a9..0fc3773 100644
--- a/src/unshar.c
+++ b/src/unshar.c
@@ -240,7 +240,7 @@ find_archive (char const * name, FILE * file, off_t start)
off_t position = ftello (file);
/* Read next line, fail if no more and no previous process. */
- if (!fgets (rw_buffer, BUFSIZ, file))
+ if (!fgets (rw_buffer, rw_base_size, file))
{
if (!start)
error (0, 0, _("Found no shell commands in %s"), name);
on value='koszko' selected='selected'>koszko
koszko-scripts
Wojtek's customized Guix
Age Commit message (Expand ) Author
2020-03-03 services: herd: Add restart-service. ...* gnu/services/herd.scm (restart-service): New exported procedure.
Mathieu Othacehe
2019-10-18 herd: Define 'shepherd-message-port'. ...* gnu/services/herd.scm (shepherd-message-port): New variable.
(display-message): Use it instead of 'current-error-port'.
Ludovic Courtès
2019-07-26 guix system: Add 'reconfigure' module. ...* guix/scripts/system/reconfigure.scm: New file.
* Makefile.am (MODULES): Add it.
* guix/scripts/system.scm (bootloader-installer-script): Export variable.
* gnu/machine/ssh.scm (switch-to-system, upgrade-shepherd-services)
(install-bootloader): Delete variable.
* gnu/machine/ssh.scm (deploy-managed-host): Rewrite procedure.
* gnu/services/herd.scm (live-service): Export variable.
* gnu/services/herd.scm (live-service-canonical-name): New variable.
* tests/services.scm (live-service): Delete variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Jakob L. Kreuze
2019-06-02 herd: Use the Guile 2.2 'setvbuf' API. ...* gnu/services/herd.scm (open-connection): Use 'block for 'setvbuf'.
Ludovic Courtès
2019-01-17 services: herd: Allow to pass arguments to start-service. ...* gnu/services/herd.scm (start-service)[arguments]: New optional argument.
Mathieu Othacehe