Fix build with Python 3 scons. Patch taken from Arch Linux: https://github.com/archlinux/svntogit-packages/blob/packages/serf/trunk/scons-python3.patch --- serf-1.3.9/SConstruct.orig 2019-07-26 17:49:30.910189251 +0000 +++ serf-1.3.9/SConstruct 2019-07-26 17:49:54.073821735 +0000 @@ -163,9 +163,9 @@ suffix='.def', src_suffix='.h') }) -match = re.search('SERF_MAJOR_VERSION ([0-9]+).*' - 'SERF_MINOR_VERSION ([0-9]+).*' - 'SERF_PATCH_VERSION ([0-9]+)', +match = re.search(b'SERF_MAJOR_VERSION ([0-9]+).*' + b'SERF_MINOR_VERSION ([0-9]+).*' + b'SERF_PATCH_VERSION ([0-9]+)', env.File('serf.h').get_contents(), re.DOTALL) MAJOR, MINOR, PATCH = [int(x) for x in match.groups()] @@ -183,7 +183,7 @@ unknown = opts.UnknownVariables() if unknown: - print 'Warning: Used unknown variables:', ', '.join(unknown.keys()) + print ('Warning: Used unknown variables:', ', '.join(unknown.keys())) apr = str(env['APR']) apu = str(env['APU']) href='/guix/refs/?id=b6021d38ab215a9de25df3d4131e5cc681e22895'>refslogtreecommitdiff
path: root/m4
AgeCommit message (Expand)Author
2022-01-14gnu: bootstrap: Add support for riscv64-linux....Efraim Flashner
2021-12-14build: Adjust 'courage level' of different systems....Efraim Flashner
2021-05-23gnu: bootstrap: Add support for powerpc-linux....Efraim Flashner
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt