Fix build with Python 3 scons. Patch taken from Arch Linux: https://github.com/archlinux/svntogit-packages/blob/packages/serf/trunk/scons-python3.patch --- serf-1.3.9/SConstruct.orig 2019-07-26 17:49:30.910189251 +0000 +++ serf-1.3.9/SConstruct 2019-07-26 17:49:54.073821735 +0000 @@ -163,9 +163,9 @@ suffix='.def', src_suffix='.h') }) -match = re.search('SERF_MAJOR_VERSION ([0-9]+).*' - 'SERF_MINOR_VERSION ([0-9]+).*' - 'SERF_PATCH_VERSION ([0-9]+)', +match = re.search(b'SERF_MAJOR_VERSION ([0-9]+).*' + b'SERF_MINOR_VERSION ([0-9]+).*' + b'SERF_PATCH_VERSION ([0-9]+)', env.File('serf.h').get_contents(), re.DOTALL) MAJOR, MINOR, PATCH = [int(x) for x in match.groups()] @@ -183,7 +183,7 @@ unknown = opts.UnknownVariables() if unknown: - print 'Warning: Used unknown variables:', ', '.join(unknown.keys()) + print ('Warning: Used unknown variables:', ', '.join(unknown.keys())) apr = str(env['APR']) apu = str(env['APU']) ix/'>summaryrefslogtreecommitdiff
path: root/gnu/machine
AgeCommit message (Expand)Author
2021-01-04machine: ssh: Do not import the host (guix config), really....Ludovic Courtès
2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas
2020-11-09machine: ssh: Do not import the host (guix config)....Ludovic Courtès
2020-11-01system: Add store-directory-prefix to boot-parameters....Miguel Ángel Arruga Vivas
2020-10-18system: Provide locale information to the bootloader....Miguel Ángel Arruga Vivas
2020-09-07linux-boot: Handle nfs-root device strings....Stefan
2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-06-28Add more missing (ice-9 format) imports....Marius Bakke
2020-06-18machine: ssh: Fix guix deploy hang when using non-DCE UUIDs....Maxim Cournoyer