From a5ecd1b2302d0def2f6f8349747022a615a9f017 Mon Sep 17 00:00:00 2001 From: Tamas K Lengyel Date: Tue, 26 May 2020 13:27:50 -0600 Subject: [PATCH] Don't limit to email with @gmail.com --- go/sendgmail/main.go | 4 ---- 1 file changed, 4 deletions(-) diff --git a/go/sendgmail/main.go b/go/sendgmail/main.go index b35ef23..405aa1b 100644 --- a/go/sendgmail/main.go +++ b/go/sendgmail/main.go @@ -30,7 +30,6 @@ import ( "log" "net/smtp" "os" - "strings" "golang.org/x/oauth2" googleOAuth2 "golang.org/x/oauth2/google" @@ -52,9 +51,6 @@ func init() { func main() { flag.Parse() - if atDomain := "@gmail.com"; !strings.HasSuffix(sender, atDomain) { - log.Fatalf("-sender must specify an %v email address.", atDomain) - } config := getConfig() tokenPath := fmt.Sprintf("%v/.sendgmail.%v.json", os.Getenv("HOME"), sender) if setUp { -- 2.32.0 Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/git-authenticate.scm
AgeCommit message (Expand)Author
2023-09-26tests: Assume ‘git’ is always available....Ludovic Courtès
2022-02-14git-authenticate: Ensure the target is a descendant of the introductory commit....Ludovic Courtès
2022-02-14git-authenticate: Test introductory commit signature verification....Ludovic Courtès
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....Attila Lendvai
2020-06-28tests: Allow 'tests/git-authenticate.scm' to run when git/gpg is missing....Ludovic Courtès
2020-06-20tests: Skip tests that requires gpg when gpg is unavailable....Ludovic Courtès
2020-06-16tests: Move OpenPGP helpers to (guix tests gnupg)....Ludovic Courtès
2020-06-12git-authenticate: Disallow SHA1 (and MD5) signatures....Ludovic Courtès
2020-06-07git-authenticate: Prevent removal of '.guix-authorizations'....Ludovic Courtès
2020-06-05git-authenticate: Add tests....Ludovic Courtès