From 854490dc4a8a6a661b4750730c3ff749519f6e36 Mon Sep 17 00:00:00 2001 From: Philip McGrath Date: Sun, 14 Nov 2021 10:14:24 -0500 Subject: [PATCH] sendgmail: accept and ignore a "-gsuite" flag Accepting a "-gsuite" flag provides compatability with https://github.com/Flameeyes/gmail-oauth2-tools/commit/eabb456 so users do not have to change their scripts or config files. Full hash of original: eabb45608ff4ce04045ff4ea92d05450e789ac81 Related to https://github.com/google/gmail-oauth2-tools/pull/17 --- go/sendgmail/main.go | 2 ++ 1 file changed, 2 insertions(+) diff --git a/go/sendgmail/main.go b/go/sendgmail/main.go index 405aa1b..5cfd0c1 100644 --- a/go/sendgmail/main.go +++ b/go/sendgmail/main.go @@ -40,6 +40,7 @@ var ( setUp bool dummyF string dummyI bool + gsuite bool ) func init() { @@ -47,6 +48,7 @@ func init() { flag.BoolVar(&setUp, "setup", false, "If true, sendgmail sets up the sender's OAuth2 token and then exits.") flag.StringVar(&dummyF, "f", "", "Dummy flag for compatibility with sendmail.") flag.BoolVar(&dummyI, "i", true, "Dummy flag for compatibility with sendmail.") + flag.BoolVar(&gsuite, "gsuite", true, "Dummy flag for compatibility with other forks of sendgmail.") } func main() { -- 2.32.0 /services/sddm.scm?id=51deacd8604b59aa434e944c73aecefd5183d13e'>treecommitdiff
path: root/gnu/services/sddm.scm
AgeCommit message (Collapse)Author
2023-05-11system: pam: Let PAM extensions add shepherd requirements.Josselin Poiret
* gnu/system/pam.scm (<pam-extension>): New record type. (pam-shepherd-service): Add Shepherd synchronization point. * gnu/services/mail.scm (dovecot-shepherd-service) * gnu/services/lightdm.scm (lightdm-shepherd-service) * gnu/services/mail.scm (opensmtpd-shepherd-service) * gnu/services/sddm.scm (sddm-shepherd-service) * gnu/services/ssh.scm (lsh-shepherd-service, openssh-shepherd-service) * gnu/services/xorg.scm (slim-shepherd-service, gdm-shepherd-service) * gnu/services/base.scm (greetd-shepherd-services): Add PAM requirement. * gnu/system/pam.scm (/etc-entry, extend-configuration, pam-root-service-type, pam-root-service) * gnu/services/authentication.scm (pam-ldap-pam-service) * gnu/services/base.scm (pam-limits-service-type) (greetd-pam-service) * gnu/services/desktop.scm (pam-gnome-keyring) * gnu/services/kerberos.scm (pam-krb5-pam-service) * gnu/services/pam-mount.scm (pam-mount-pam-service): Adapt to use pam-extension. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-04-07services: sddm: Remove 'sddm-service' procedure.Bruno Victal
* gnu/services/sddm.scm (sddm-service): Remove procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2020-11-18services: SDDM: Wait for elogind before starting.Marius Bakke
Fixes <https://bugs.gnu.org/44669>. * gnu/services/sddm.scm (sddm-shepherd-service)[requirement]: Add elogind.
2020-04-19services: sddm: Have sddm provision xorg-server.Efraim Flashner
* gnu/services/sddm.scm (sddm-shepherd-service)[shepherd-service]: Have sddm provision 'xorg-server like the other display managers.
2020-03-01services: set-xorg-configuration: handle slim and sddmJakub Kądziołka
* gnu/services/xorg.scm (handle-xorg-configuration): New syntax. (gdm-service-type, slim-service-type): Use handle-xorg-configuration. * gnu/services/sddm.scm (sddm-service-type): Likewise.
2020-02-16doc: Fix typo.Efraim Flashner
* doc/guix.texi (X Window)[sddm-service-type]: SSDM -> SDDM typo fix. [sddm-configuration]: Also list 'maya' theme. * gnu/services/sddm.scm (sddm-service): Fix typo in doc string. (sddm-configuration): Also list 'maya' theme.