This patch was submitted upstream:
https://github.com/scheme/scsh/pull/46
diff --git a/scheme/lib-dirs.scm b/scheme/lib-dirs.scm
index a1fc009..c630fb4 100644
--- a/scheme/lib-dirs.scm
+++ b/scheme/lib-dirs.scm
@@ -75,6 +75,7 @@
(let ((val (read)))
(cond ((eof-object? val) '())
((string? val) (cons val (recur)))
+ ((symbol? val) (cons (symbol->string val) (recur)))
((not val) (append default-lib-dirs (recur)))
(else
(error
rm'>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-08-18 | home: Fix typo in parcimonie configuration....* gnu/home/services/gnupg.scm (<home-parcimonie-configuration>)
[gnupg-aleady-torified?]: Rename to ‘gnupg-already-torified?’.
Change-Id: I0687f67a5cef410b8b1d579c57b318b9d269e0d0
| Tobias Geerinckx-Rice |
2024-07-26 | home: Set 700 permissions on .gnupg with home-gpg-agent-service...* gnu/home/services/gnupg.scm (gpg-agent-activation): New variable.
(home-gpg-agent-service-type) [extensions]: Extend
home-activation-service-type.
Change-Id: If3365c6cade2b03ee53a466ce1d63a5cdf654d6c
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Richard Sent |
2023-09-04 | home: Add parcimonie service....* gnu/home/services/gnupg.scm (home-parcimonie-service-type,
home-parcimonie-configuration): New variables.
* doc/guix.texi (GNU Privacy Guard): Document it.
| Efraim Flashner |
2023-04-08 | home: Add gpg-agent service....* gnu/home/services/gnupg.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* doc/guix.texi (GNU Privacy Guard): New node.
(Secure Shell): Link to it.
| Ludovic Courtès |