Workaround for PATH_MAX usage on the Hurd. Taken from https://salsa.debian.org/debian/screen/-/blob/master/debian/patches/61-default-PATH_MAX-if-undefined-for-hurd.patch Description: Set PATH_MAX to 4096 if undefined Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0. Author: Axel Beckert Bug: https://savannah.gnu.org/bugs/?50089 Last-Updated: 2017-01-18 --- a/tty.sh +++ b/tty.sh @@ -1478,6 +1478,13 @@ return 0; } +/* + * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd + */ + +#ifndef PATH_MAX +#define PATH_MAX 4096 +#endif int CheckTtyname (char *tty) { --- a/screen.h +++ b/screen.h @@ -109,6 +109,13 @@ # define DEFAULT_BUFFERFILE "/tmp/screen-exchange" #endif +/* + * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd + */ + +#ifndef PATH_MAX +#define PATH_MAX 4096 +#endif #if defined(hpux) && !(defined(VSUSP) && defined(VDSUSP) && defined(VWERASE) && defined(VLNEXT)) # define HPUX_LTCHARS_HACK class='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/adns.scm
AgeCommit message (Expand)Author
2023-07-20gnu: c-ares: Skip failing tests on the Hurd....* gnu/packages/adns.scm (c-ares)[arguments: When building natively on the Hurd, add phases 'skip-tests' and 'filter-hurd-tests'. Janneke Nieuwenhuizen
2022-06-26gnu: c-ares: Update to 1.18.1....* gnu/packages/adns.scm (c-ares): Update to 1.18.1. Marius Bakke
2021-12-23gnu: c-ares: Enable tests....* gnu/packages/adns.scm (c-ares)[arguments]: Enable tests. Jelle Licht
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-15gnu: Add c-ares-for-node....* gnu/packages/adns.scm (c-ares-for-node): New variable. Co-authored-by: Marius Bakke <marius@gnu.org> Jelle Licht
2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe
2021-10-17gnu: c-ares: Update to 1.17.2....* gnu/packages/adns.scm (c-ares/fixed): Update to 1.17.2. Tobias Geerinckx-Rice