Fixes make with -j, otherwise scotch.h may not be generated by the time make
tries to compile library_graph_diam.o et al.
Reported upstream at
https://gforge.inria.fr/tracker/index.php?func=detail&aid=21651&group_id=248&atid=1081
diff --git a/src/libscotch/Makefile b/src/libscotch/Makefile
index 9898894..b0ee14c 100644
--- a/src/libscotch/Makefile
+++ b/src/libscotch/Makefile
@@ -2229,6 +2229,28 @@ library_graph_color_f$(OBJ) : library_graph_color_f.c \
common.h \
scotch.h
+library_graph_diam$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ graph.h \
+ scotch.h
+
+library_graph_diam_f$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ scotch.h
+
+library_graph_induce$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ graph.h \
+ scotch.h
+
+library_graph_induce_f$(OBJ) : library_graph_diam.c \
+ module.h \
+ common.h \
+ scotch.h
+
library_graph_io_chac$(OBJ) : library_graph_io_chac.c \
module.h \
common.h \
='/guix/refs/?id=428327e6be19155729683065e9bbc1b7e6c9cbbd'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-08-25 | image: Add mbr-raw-image-type and use by default....* gnu/system/image.scm (mbr-disk-image, mbr-raw-image-type): New variables.
(qcow2-image-type): Inherit mbr-disk-image.
* guix/scripts/system.scm (%default-options): Use mbr-raw-image-type by
default.
* gnu/tests/install.scm (run-install): Use mbr-raw in the tests.
* doc/guix-cookbook.texi (Guix System Image API): Update the list of image
types.
* doc/guix.texi (Invoking guix system, System Images, image-type Reference):
Add mbr-raw and switch documented default to it.
| Josselin Poiret |