commit b286d92af7468164c155c70d38213211b296fdfe Author: Douglas Katzman Date: Wed Jan 10 11:46:55 2024 -0500 Fix riscv build diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp index ce46d24ac..a16380293 100644 --- a/src/compiler/riscv/float.lisp +++ b/src/compiler/riscv/float.lisp @@ -578,7 +578,7 @@ (:results (res :scs (double-reg))) (:arg-types signed-num) (:result-types double-float) - (:translate make-double-float) + (:translate %make-double-float) (:policy :fast-safe) (:generator 2 (inst fmvx-> :double res bits))) form'>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/images/novena.scm
AgeCommit message (Collapse)Author
2021-02-17scripts: system: Accept <image> records as input.Mathieu Othacehe
* guix/scripts/system.scm (system-derivation-for-action): Replace "os" argument by "image". Remove "image-size", "image-type", "label" and "volatile-root?" arguments. (perform-action): Ditto. (process-action): Construct the <image> record and pass it to "perform-action" procedure. * tests/guix-system.sh: Adapt accordingly. * gnu/system/images/hurd.scm: Return the default image. * gnu/system/images/novena.scm: Ditto. * gnu/system/images/pine64.scm: Ditto. * gnu/system/images/pinebook-pro.scm Ditto.
2021-01-10system: image: Fix root offset on rockchip platforms.Mathieu Othacehe
Fixes: <https://issues.guix.gnu.org/45584>. * gnu/system/image.scm (arm32-disk-image, arm64-disk-image): Turn into procedures, taking the root partition offset as argument. * gnu/system/images/novena.scm (novena-image-type): Adapt accordingly. * gnu/system/images/pine64.scm (pine64-image-type): Ditto. * gnu/system/images/pinebook-pro.scm (pinebook-pro-image-type): Use a 9MiB offset for the root partition.
2020-12-05images: novena: Make boot settings and RTC accessible.Danny Milosavljevic
* gnu/system/images/novena.scm (novena-barebones-os)[initrd-modules]: Add i2c-dev.
2020-12-03images: novena: Replace agetty-service by term-auto.Danny Milosavljevic
* gnu/system/images/novena.scm (novena-barebones-os)[kernel-arguments]: New field. [services]: Remove field.
2020-12-03images: Add novena-image-type, novena-barebones-raw-image, novena-barebones-os.Danny Milosavljevic
* gnu/system/images/novena.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.