The standard CIEL REPL includes Quicklisp. We remove it for packaging
with Guix.
The default Quicklisp-based build procedure removes one dependency
relation from the system definition for ciel/repl and replaces it by
an explicit load command using Quicklisp, as a workaround to some build
issue. Fortunately we don't have this issue with Guix, so we go back
to letting ASDF manage this dependency relation.
--- a/repl.lisp
+++ b/repl.lisp
@@ -1,8 +1,5 @@
;; #!/usr/bin/sbcl --script
-(load "~/quicklisp/setup")
-(let ((*standard-output* (make-broadcast-stream)))
- (ql:quickload "cl-readline"))
(uiop:define-package :sbcli
(:use :common-lisp :trivial-package-local-nicknames)
(:import-from :magic-ed
--- a/ciel.asd
+++ b/ciel.asd
@@ -179,7 +179,7 @@
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
(asdf:defsystem "ciel/repl"
:description "readline REPL for CIEL with quality of life improvements."
- :depends-on (;; :ciel ;; let's avoid, it could run side effects twice (like a defparameter set then reset).
+ :depends-on (:ciel
;; deps
:cl-readline
:lisp-critic ;; it would be nice to integrate it with Slime.
m'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-12-02 | gnu: Add pcg-c....* gnu/packages/c.scm (pcg-c): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| David Elsing |
2023-11-15 | gnu: mimalloc: Update to 2.1.2....* gnu/packages/c.scm (mimalloc): Update to 2.1.2.
Change-Id: I20ff922250f57beabb427d72e82579e0059fd4f2
| Efraim Flashner |
2023-11-15 | gnu: mimalloc: Fix building on powerpc-linux....* gnu/packages/c.scm (mimalloc)[arguments]: When building for
powerpc-linux add a configure-flag to use libatomic.
Change-Id: I41062686186640bc4c685a0ee5de1e613040dfb9
| Efraim Flashner |
2023-09-08 | gnu: Add nsync....* gnu/packages/c.scm (nsync): New variable.
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
| Andy Tai |