This patch prevents a code execution vector involving terminal escape sequences when rxvt-unicode is in "secure mode". This change was spurred by the following conversation on the oss-security mailing list: Problem description and proof of concept: http://seclists.org/oss-sec/2017/q2/190 Upstream response: http://seclists.org/oss-sec/2017/q2/291 Patch copied from upstream source repository: http://cvs.schmorp.de/rxvt-unicode/src/command.C?r1=1.582&r2=1.583 --- rxvt-unicode/src/command.C 2016/07/14 05:33:26 1.582 +++ rxvt-unicode/src/command.C 2017/05/18 02:43:18 1.583 @@ -2695,7 +2695,7 @@ /* kidnapped escape sequence: Should be 8.3.48 */ case C1_ESA: /* ESC G */ // used by original rxvt for rob nations own graphics mode - if (cmd_getc () == 'Q') + if (cmd_getc () == 'Q' && option (Opt_insecure)) tt_printf ("\033G0\012"); /* query graphics - no graphics */ break; @@ -2914,7 +2914,7 @@ break; case CSI_CUB: /* 8.3.18: (1) CURSOR LEFT */ - case CSI_HPB: /* 8.3.59: (1) CHARACTER POSITION BACKWARD */ + case CSI_HPB: /* 8.3.59: (1) CHARACTER POSITION BACKWARD */ #ifdef ISO6429 arg[0] = -arg[0]; #else /* emulate common DEC VTs */ 775e76c0a898c7d4b53691d1932fc0e6eb'>treecommitdiff
path: root/gnu/packages/php.scm
AgeCommit message (Expand)Author
2021-12-16gnu: php: Properly fix openssl_x509_checkpurpose_basic.phpt....* gnu/packages/php.scm (php)[source]: Add patch. * gnu/packages/patches/php-openssl_x509_checkpurpose_basic.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Thanks to Diego Nicola Barbato <dnbarbato@posteo.de> Tobias Geerinckx-Rice
2021-12-16gnu: php: Disable yet another failing test....* gnu/packages/php.scm (php)[arguments]: Delete the openssl_x509_checkpurpose_basic.phpt test. Tobias Geerinckx-Rice
2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus
2021-11-28gnu: php: Remove extra glibc input....* gnu/packages/php.scm (php)[arguments]: Use build-system's libc for gettext. [inputs]: Remove glibc. Efraim Flashner
2021-11-28gnu: php: Update to 7.4.26....* gnu/packages/php.scm (php): Update to 7.4.26. Efraim Flashner
2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-10-23gnu: php: Update to 7.4.25 [security fixes]....* gnu/packages/php.scm (php): Update to 7.4.25. [source]: Don't explicitly return #t from snippet. Tobias Geerinckx-Rice
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-10-05gnu: php: Patch failing test case....Fixes a failing test case in PHP (Zend/tests/bug74093.phpt). See <https://github.com/php/php-src/pull/7555/files> for upstream status. * gnu/packages/php.scm (php)[source]: Add patch. * gnu/packages/patches/php-bug-74093-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Ryan Sundberg via Guix-patches via