Fix the build when using igraph >= 0.10. Retrieved from: https://sourceforge.net/p/rankwidth/tickets/2/. --- rw-0.9/simplerw.c.newigraph 2017-02-14 00:20:35.000000000 +0900 +++ rw-0.9/simplerw.c 2022-09-11 19:39:47.033917305 +0900 @@ -134,7 +134,11 @@ int read_graph(const char *format, const igraph_destroy(&igraph); return(-1); } +#if (IGRAPH_VERSION_MAJOR >= 1) || ((IGRAPH_VERSION_MAJOR == 0) && (IGRAPH_VERSION_MINOR >= 10)) + igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, NULL, IGRAPH_LOOPS_ONCE); +#else igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, 0); +#endif igraph_destroy(&igraph); if(igraph_matrix_nrow(&imatrix) > MAX_VERTICES) { 6c2'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-pack-relocatable.sh
AgeCommit message (Expand)Author
2020-12-04tests: pack-relocatable: Ensure commands can run in the current namespace....Paul Garlick
2020-10-31pack: Relocatable wrapper leaves root available to child processes....Ludovic Courtès
2020-10-30guix: pack: Only wrap executable files....Eric Bavier
2020-09-28tests: Simplify shell exit status negation;...Eric Bavier
2020-07-28pack: "fakechroot" engine always creates its store....Ludovic Courtès
2020-07-28pack: "fakechroot" execution engine can load its audit module....Ludovic Courtès
2020-07-24pack: '-R' applies to propagated inputs too....Ludovic Courtès
2020-05-14pack: Add relocation via ld.so and fakechroot....Ludovic Courtès
2020-05-14pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable....Ludovic Courtès
2020-04-24pack: 'guix pack -R' wrapper correctly reports exit code....Ludovic Courtès
2019-08-23pack: '-R' honors the requested output....Ludovic Courtès
2019-05-18pack: '--localstatedir' and '-R' tests gracefully handle missing /gnu/store....Ludovic Courtès
2019-05-09tests: Ensure 'unshare' works before relying on it....Ludovic Courtès
2019-03-15pack: "-RR" produces PRoot-enabled relocatable binaries....Ludovic Courtès