Fix the build when using igraph >= 0.10. Retrieved from: https://sourceforge.net/p/rankwidth/tickets/2/. --- rw-0.9/simplerw.c.newigraph 2017-02-14 00:20:35.000000000 +0900 +++ rw-0.9/simplerw.c 2022-09-11 19:39:47.033917305 +0900 @@ -134,7 +134,11 @@ int read_graph(const char *format, const igraph_destroy(&igraph); return(-1); } +#if (IGRAPH_VERSION_MAJOR >= 1) || ((IGRAPH_VERSION_MAJOR == 0) && (IGRAPH_VERSION_MINOR >= 10)) + igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, NULL, IGRAPH_LOOPS_ONCE); +#else igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, 0); +#endif igraph_destroy(&igraph); if(igraph_matrix_nrow(&imatrix) > MAX_VERTICES) { hidden' name='id' value='fb624c919fe55f4e61a82bbd35579c0a4487b3c4'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-03-11 13:39:38 +0000
committerLars-Dominik Braun <lars@6xq.net>2023-03-12 11:04:06 +0100
commitfb624c919fe55f4e61a82bbd35579c0a4487b3c4 (patch)
treeedb1428138e888a2a123466f1c39015af24348f6 /gnu/packages
parentf19ab875ff92cbd3d7e06ccb6a4ff9f55b63c857 (diff)
downloadguix-fb624c919fe55f4e61a82bbd35579c0a4487b3c4.tar.gz
guix-fb624c919fe55f4e61a82bbd35579c0a4487b3c4.zip
gnu: python-minikanren: Remove python-pre-commit.
* gnu/packages/python-xyz.scm (python-minikanren)[native-inputs]: Remove python-pre-commit. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages')