Bootstrap tests failed with local stage0 cargo and rustc Backported changes from https://github.com/rust-lang/rust/pull/51977 From 0834d9d771e912f51deca6c25699e44734624546 Mon Sep 17 00:00:00 2001 From: Nikolai Merinov Date: Mon, 2 Jul 2018 01:45:35 +0500 Subject: [PATCH] bootstrap: tests should use rustc from config.toml Tests should always use "rustc" and "cargo" from config.toml instead of assuming that stage0 binaries was downloaded to build directory. --- src/bootstrap/bootstrap.py | 2 ++ src/bootstrap/config.rs | 6 ++---- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py index 487440becf..1701f7b83a 100644 --- a/src/bootstrap/bootstrap.py +++ b/src/bootstrap/bootstrap.py @@ -788,6 +788,8 @@ def bootstrap(help_triggered): env["BOOTSTRAP_PARENT_ID"] = str(os.getpid()) env["BOOTSTRAP_PYTHON"] = sys.executable env["BUILD_DIR"] = build.build_dir + env["CARGO"] = build.cargo() + env["RUSTC"] = build.rustc() run(args, env=env, verbose=build.verbose) diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs index 6dd6291be2..d1a0deb583 100644 --- a/src/bootstrap/config.rs +++ b/src/bootstrap/config.rs @@ -23,7 +23,6 @@ use std::cmp; use num_cpus; use toml; -use util::exe; use cache::{INTERNER, Interned}; use flags::Flags; pub use flags::Subcommand; @@ -362,9 +361,8 @@ impl Config { config.src = Config::path_from_python("SRC"); config.out = Config::path_from_python("BUILD_DIR"); - let stage0_root = config.out.join(&config.build).join("stage0/bin"); - config.initial_rustc = stage0_root.join(exe("rustc", &config.build)); - config.initial_cargo = stage0_root.join(exe("cargo", &config.build)); + config.initial_rustc = Config::path_from_python("RUSTC"); + config.initial_cargo = Config::path_from_python("CARGO"); config } -- 2.17.1 form>
path: root/gnu/services/admin.scm
AgeCommit message (Expand)Author
2018-03-22gnu: shepherd: Update to 0.4.0....Ludovic Courtès
2018-03-22services: rottlog: Add /var/log/debug to '%default-rotations'....Ludovic Courtès
2017-11-05services: Add 'description' fields....Ludovic Courtès
2017-08-09services: admin: Simplify the handling of the Tailon debug? option....Christopher Baines
2017-08-09services: Update the Tailon service for Tailon 1.3.0....Christopher Baines
2017-08-09services: Add missing wrap-lines option to tailon....Christopher Baines
2017-07-29gnu: services: admin: Add tailon....Christopher Baines
2017-06-12services: rottlog: Make extensible....Ludovic Courtès
2017-06-12services: rottlog: Define <log-rotation> objects....Ludovic Courtès
2017-04-16services: Add a default value to various service types....Ludovic Courtès
2016-12-19services: guix: Add 'log-file' configuration option....Ludovic Courtès
2016-10-03services: rottlog: Add Rottlog to the global profile....Ludovic Courtès
2016-10-03services: rottlog: Improve default weekly rotations....Ludovic Courtès
2016-10-03services: Add rottlog....Jan Nieuwenhuizen