See https://github.com/thepowersgang/mrustc/archive/v0.8.0.tar.gz --- rustc-1.19.0-src-orig/src/libcore/intrinsics.rs +++ rustc-1.19.0-src/src/libcore/intrinsics.rs @@ -678,5 +678,9 @@ pub fn min_align_of_val(_: &T) -> usize; + /// Obtain the length of a slice pointer + #[cfg(rust_compiler="mrustc")] + pub fn mrustc_slice_len(pointer: *const [T]) -> usize; + /// Gets a static string slice containing the name of a type. pub fn type_name() -> &'static str; --- rustc-1.19.0-src-orig/src/libcore/slice/mod.rs +++ rustc-1.19.0-src/src/libcore/slice/mod.rs @@ -413,6 +413,8 @@ #[inline] fn len(&self) -> usize { - unsafe { - mem::transmute::<&[T], Repr>(self).len - } + #[cfg(not(rust_compiler="mrustc"))] + let rv = unsafe { mem::transmute::<&[T], Repr>(self).len }; + #[cfg(rust_compiler="mrustc")] + let rv = unsafe { ::intrinsics::mrustc_slice_len(self) }; + rv } r>
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès
2020-01-15gnu: util-linux: Move libraries to separate output....Marius Bakke
2019-12-04gnu: Remove duplicate nlohmann-json-cpp package....Marius Bakke
2019-10-12gnu: python-jupyter-kernel-test: Use PYTHON-VERSION....Marius Bakke
2019-09-18gnu: Add Xeus....Ludovic Courtès
2019-09-18gnu: Add python-jupyter-kernel-test....Ludovic Courtès
2019-09-18gnu: Add python-jupyter-kernel-mgmt....Ludovic Courtès
2019-09-18gnu: Add python-jupyter-protocol....Ludovic Courtès