Fix test failures that occur when nokogiri is using system libxml: https://github.com/rgrove/sanitize/issues/198 Taken from upstream: https://github.com/rgrove/sanitize/commit/21da9b62baf9ea659811d92e6b574130aee57eba diff --git a/test/test_malicious_html.rb b/test/test_malicious_html.rb index 2c23074..0756de0 100644 --- a/test/test_malicious_html.rb +++ b/test/test_malicious_html.rb @@ -135,6 +135,8 @@ # The relevant libxml2 code is here: # describe 'unsafe libxml2 server-side includes in attributes' do + using_unpatched_libxml2 = Nokogiri::VersionInfo.instance.libxml2_using_system? + tag_configs = [ { tag_name: 'a', @@ -166,6 +168,8 @@ input = %[<#{tag_name} #{attr_name}='example.com'>foo] it 'should escape unsafe characters in attributes' do + skip "behavior should only exist in nokogiri's patched libxml" if using_unpatched_libxml2 + # This uses Nokogumbo's HTML-compliant serializer rather than # libxml2's. @s.fragment(input). @@ -191,6 +195,8 @@ input = %[<#{tag_name} #{attr_name}='example.com'>foo] it 'should not escape characters unnecessarily' do + skip "behavior should only exist in nokogiri's patched libxml" if using_unpatched_libxml2 + # This uses Nokogumbo's HTML-compliant serializer rather than # libxml2's. @s.fragment(input). input type='hidden' name='id' value='03009f2a2bb5c94e94735d2ff9314502412066a4'/>
path: root/po/packages/zh_CN.po
AgeCommit message (Expand)Author
2022-04-02nls: Update translations....* po/packages/fi.po: New file. * po/packages/LINGUAS: Add it. Julien Lepiller
2022-03-01nls: Update translations....* po/doc/guix-cookbook.uk.po: New file. * po/doc/local.mk: Add uk cookbook. * doc/local.mk: Add uk cookbook. * po/guix/fa.po: New file. * po/guix/uk.po: New file. * po/guix/LINGUAS: Add fa and uk. Julien Lepiller
2022-02-04nls: Update translations....* po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add it. * doc/local.mk: Add pt_BR cookbook. Julien Lepiller
2022-01-09nls: Update translations....* po/doc/guix-cookbook.fi.po: New file. * po/doc/guix-manual.fi.po: New file. * po/doc/local.mk: Add them. * doc/local.mk: Add them. * po/guix/fi.po: New file. * po/guix/LINGUAS: Add it. Julien Lepiller
2021-12-04nls: Update translations.Julien Lepiller
2021-11-06nls: Update translations....* po/doc/guix-cookbook.es.po: New file. * po/doc/local.mk: Add 'es' cookbook. * doc/local.mk: Add 'es' cookbook. Julien Lepiller
2021-10-17nls: Update translations.Julien Lepiller
2021-09-02nls: Update translations....* po/packages/it.po: New file. * po/packages/LINGUAS: Add `it'. * po/*/*.po: Update translations. Julien Lepiller
2021-08-04nls: Update translations....* po/doc/guix-cookbook.ru.po: New file. * po/doc/guix-cookbook.sk.po: New file. * po/*/*.po: Update translations. * doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk. (info_TEXINFOS): Add Russian and Slovak cookbooks. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po files. Julien Lepiller
2021-05-10nls: Update translations.Maxim Cournoyer
2021-04-18nls: Update 'zh_CN' translations.Julien Lepiller