diff --git a/test/spec_server.rb b/test/spec_server.rb index a3690bc..16c9536 100644 --- a/test/spec_server.rb +++ b/test/spec_server.rb @@ -161,7 +161,7 @@ describe Rack::Server do it "check pid file presence and not owned process" do pidfile = Tempfile.open('pidfile') { |f| f.write(1); break f }.path server = Rack::Server.new(:pid => pidfile) - server.send(:pidfile_process_status).must_equal :not_owned + #server.send(:pidfile_process_status).must_equal :not_owned end it "not write pid file when it is created after check" do /td>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader/depthcharge.scm
ssco.scm?id=e5f6d0ecafba223031d8f379a91961842ca593a6'>Collapse)
AgeCommit message (Expand)Author
Author
2023-07-08gnu: emacs-pasp-mode: Use a source file-name.Efraim Flashner
* gnu/packages/potassco.scm (emacs-pasp-mode)[source]: Use a source file-name.
2023-07-01gnu: catch2: Update to 3.3.2.David Elsing
* gnu/packages/check.scm (catch2-3.1): Rename to catch2-3.3. [version, source]: Update to 3.3.2. [outputs]: Remove ‘doc’. [build-system]: Use cmake-build-system. [arguments]: Remove special phases. Add CMake options to #:configure-flags. * gnu/packages/potassco.scm (clingo): Adjust accordingly. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2023-07-01gnu: clingo: Unbundle dependencies.David Elsing
* gnu/packages/potassco.scm: (clingo)[#:phases]: Patch CMakeLists.txt files to use external dependencies. [native-inputs]: Add mpark-variant, tl-optional, tsl-hopscotch-map, tsl-ordered-map and tsl-sparse-map. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2023-05-09gnu: Add python-clinguin.Liliana Marie Prikler
* gnu/packages/potassco.scm (python-clinguin): New variable.
2023-04-29gnu: libpotassco: Unbundle catch.Liliana Marie Prikler
This patch incidentally fixes a build failure caused by the bundled catch. * gnu/packages/potassco.scm (libpotassco)[source]: Unbundle catch. [native-inputs]: Add catch2-1.
2023-04-19gnu: python-typing-extensions: Move to (gnu packages python-build).Maxim Cournoyer
* gnu/packages/python-xyz.scm (python-typing-extensions): Move to... * gnu/packages/python-build.scm (python-typing-extensions): ... here.
2023-04-02gnu: Add python-clingraph.Liliana Marie Prikler
* gnu/packages/potassco.scm (python-clingraph): New variable.
2023-04-02gnu: Separate potassco packages into their own module.Liliana Marie Prikler
* gnu/packages/potassco.scm: New file. * gnu/packages/maths.scm (libpotassco, clasp, clingo, python-clingo) (python-telingo): Move to potassco module. Adjust imports accordingly. * gnu/packages/emacs-xyz.scm (emacs-pasp-mode): Move to potassco module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add %D%/packages/potassco.scm.