Description: Removed some unnecessary test setup such as SimpleCov and minitest-reporters. diff --git a/test/helper.rb b/test/helper.rb index ed3133c6..4f5d4f1b 100644 --- a/test/helper.rb +++ b/test/helper.rb @@ -13,22 +13,10 @@ # - NOKOGIRI_GC: read more in test/test_memory_leak.rb # -require "simplecov" -SimpleCov.start do - add_filter "/test/" - enable_coverage :branch -end - $VERBOSE = true require "minitest/autorun" require "minitest/benchmark" -require "minitest/reporters" - -nokogiri_minitest_reporters_options = { color: true, slow_count: 10, detailed_skip: false } -nokogiri_minitest_reporters_options[:fast_fail] = true if ENV["NOKOGIRI_TEST_FAIL_FAST"] -puts "Minitest::Reporters options: #{nokogiri_minitest_reporters_options}" -Minitest::Reporters.use!(Minitest::Reporters::DefaultReporter.new(nokogiri_minitest_reporters_options)) require "fileutils" require "tempfile" /td> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-home.sh
AgeCommit message (Expand)Author
2023-08-25tests: guix-home: Fix description search for home-mcron....Josselin Poiret
2023-07-11home: services: bash: Properly quote shell aliases....Ludovic Courtès
2023-04-21tests: Fix checks for expected failures....Eric Bavier
2023-03-26tests: Fix guix-home.sh when guix isn't installed...Ting-Wei Lan
2023-01-09home: environment-variables: Fix escaping....Andrew Tropin
2023-01-09home: environment-variables: Return support for file-likes and gexps....Andrew Tropin
2023-01-05home: services: environment-variables: Add support for literal strings....Ludovic Courtès
2022-08-05tests: Make tests inside container reproducible....Andrew Tropin
2022-07-14home: services: environment-variables: Double-quote values....Ludovic Courtès
2022-07-14home: services: shells: Double-quote environment variable values....Ludovic Courtès
2022-04-19tests: Adjust 'guix home' test to 'home-files-service-type' changes....Ludovic Courtès
2022-03-19guix home: Add 'container' command....Ludovic Courtès
2022-03-18guix home: Implement the 'extension-graph' and 'shepherd-graph' actions....Ludovic Courtès
2022-03-10tests: Check 'guix home reconfigure' for a second generation....Ludovic Courtès
2022-03-10tests: Simplify use of 'local-file' in 'tests/guix-home.sh'....Ludovic Courtès
2022-03-10tests: Make sure 'guix home reconfigure' backs up files....Ludovic Courtès