Description: Removed some unnecessary test setup such as SimpleCov and
minitest-reporters.
diff --git a/test/helper.rb b/test/helper.rb
index ed3133c6..4f5d4f1b 100644
--- a/test/helper.rb
+++ b/test/helper.rb
@@ -13,22 +13,10 @@
# - NOKOGIRI_GC: read more in test/test_memory_leak.rb
#
-require "simplecov"
-SimpleCov.start do
- add_filter "/test/"
- enable_coverage :branch
-end
-
$VERBOSE = true
require "minitest/autorun"
require "minitest/benchmark"
-require "minitest/reporters"
-
-nokogiri_minitest_reporters_options = { color: true, slow_count: 10, detailed_skip: false }
-nokogiri_minitest_reporters_options[:fast_fail] = true if ENV["NOKOGIRI_TEST_FAIL_FAST"]
-puts "Minitest::Reporters options: #{nokogiri_minitest_reporters_options}"
-Minitest::Reporters.use!(Minitest::Reporters::DefaultReporter.new(nokogiri_minitest_reporters_options))
require "fileutils"
require "tempfile"
rm>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-08-06 | gnu: chrony: Use G-expressions....* gnu/packages/ntp.scm (chrony)[arguments]:
Rewrite as G-expressions.
| Tobias Geerinckx-Rice |
2023-08-06 | gnu: chrony: Update to 4.4....* gnu/packages/ntp.scm (chrony): Update to 4.4.
| Tobias Geerinckx-Rice |
2023-08-12 | gnu: ntp: Fix cross-compilation inputs....* gnu/packages/ntp.scm (ntp)[inputs]: Use `target-linux?' instead of
the manual string comparison as it would not add the libcap input
correctly when cross-compiling as the platform ends in `-linux-gnu'
unlike the system string which ends in `-linux'.
Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Jean-Pierre De Jesus DIAZ |
2023-07-16 | gnu: ntp: Use G-expressions....* gnu/packages/ntp.scm (ntp)[arguments]:
Rewrite as G-expressions.
| Tobias Geerinckx-Rice |
2023-07-16 | gnu: ntp: Remove input labels....* gnu/packages/ntp.scm (ntp)[inputs]:
Remove input labels.
| Tobias Geerinckx-Rice |
2023-07-16 | gnu: ntp: Update to 4.2.8p17....* gnu/packages/ntp.scm (ntp): Update to 4.2.8p17.
[arguments]: Don't explicitly return #t from phases.
[source]: Remove obsolete patches.
| Tobias Geerinckx-Rice |