Description: Removed some unnecessary test setup such as SimpleCov and
minitest-reporters.
diff --git a/test/helper.rb b/test/helper.rb
index ed3133c6..4f5d4f1b 100644
--- a/test/helper.rb
+++ b/test/helper.rb
@@ -13,22 +13,10 @@
# - NOKOGIRI_GC: read more in test/test_memory_leak.rb
#
-require "simplecov"
-SimpleCov.start do
- add_filter "/test/"
- enable_coverage :branch
-end
-
$VERBOSE = true
require "minitest/autorun"
require "minitest/benchmark"
-require "minitest/reporters"
-
-nokogiri_minitest_reporters_options = { color: true, slow_count: 10, detailed_skip: false }
-nokogiri_minitest_reporters_options[:fast_fail] = true if ENV["NOKOGIRI_TEST_FAIL_FAST"]
-puts "Minitest::Reporters options: #{nokogiri_minitest_reporters_options}"
-Minitest::Reporters.use!(Minitest::Reporters::DefaultReporter.new(nokogiri_minitest_reporters_options))
require "fileutils"
require "tempfile"
h'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-07-23 | gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this…
(fuse-2): …to this, and…
(fuse-3): …rename this…
(fuse): …to this!
(fuse-static): Rename this…
(fuse-2-static): …to this.
Adjust all users.
| Tobias Geerinckx-Rice |
2022-12-23 | gnu: ceph: Update to 17.2.5....* gnu/packages/storage.scm (ceph): Update to 17.2.5.
[source]: Remove obsolete patches; remove bundled sources for arrow.
[arguments]: Disable parallel build; use system arrow.
[inputs]: Drop input labels; add apache-thrift, apache-arrow-for-ceph, and
utf8proc.
* gnu/packages/patches/ceph-boost-compat.patch: Delete file.
* gnu/packages/patches/ceph-rocksdb-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove them.
| Ricardo Wurmus |
2022-11-06 | gnu: fmt: Update to 9.1.0....* gnu/packages/pretty-print.scm (fmt): Update to 9.1.0.
(fmt-8): New variable.
* gnu/packages/hyperledger.scm (hyperledger-iroha)
[snippet]: Delete trailing #t.
[native-inputs]: Re-indent. Replace fmt with fmt-8.
* gnu/packages/networking.scm (opendht) [inputs]: Replace fmt with fmt-8.
* gnu/packages/storage.scm (ceph): Likewise.
* gnu/packages/video.scm (mkvtoolnix): Likewise.
* gnu/packages/aidc.scm (zxing-cpp): Likewise.
* gnu/packages/wm.scm (waybar): Likewise.
* gnu/packages/geo.scm (osm2pgsql): Likewise.
* gnu/packages/graphics.scm (openimageio): Likewise.
* gnu/packages/build-tools.scm (bear): Likewise.
* gnu/packages/networking.scm (restinio): Likewise.
| Maxim Cournoyer |