From 407c6a5db6c1f1cfb40bd6113f07f067d07885a4 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?V=C3=ADt=20Ondruch?= Origin: https://github.com/mustache/mustache/pull/258 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954503 Date: Mon, 27 Apr 2020 11:16:17 +0200 Subject: [PATCH] Fix test race condition. The test suite randomly fails with errors such as: ~~~ 1) Failure: AutoloadingTest#test_autoload_lowercase [/builddir/build/BUILD/mustache-1.1.1/usr/share/gems/gems/mustache-1.1.1/test/autoloading_test.rb:17]: Expected: Comments Actual: nil ~~~ This happens when `test_namespaced*` test cases are executed earlier than the remaining test cases, because they are defining `view_namespace` but not cleaning up afterwards. --- test/autoloading_test.rb | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/test/autoloading_test.rb b/test/autoloading_test.rb index 0a7ad762..77eb3557 100644 --- a/test/autoloading_test.rb +++ b/test/autoloading_test.rb @@ -7,6 +7,10 @@ def setup Mustache.view_path = File.dirname(__FILE__) + '/fixtures' end + def teardown + Mustache.remove_instance_variable(:@view_namespace) if Mustache.instance_variable_defined?(:@view_namespace) + end + def test_autoload klass = Mustache.view_class(:Comments) assert_equal Comments, klass x/diff/gnu/system?id=e0b4cf6019f520aef4c3d0ea9858a8f1fa215d22'>diff
path: root/gnu/system
AgeCommit message (Expand)Author
2023-07-13system: hurd: Add netdde to %base-packages/hurd....Janneke Nieuwenhuizen
2023-07-13services: childhurd: Bump default qemu memory to 2048MB....Janneke Nieuwenhuizen
2023-07-07image: Prefer gpt partition table for efi images...Sergey Trofimov
2023-06-24linux-container: Pass '--disable-chroot' to 'guix-daemon'....Ludovic Courtès
2023-06-18uuid: Fix NTFS UUID stringification....Tobias Geerinckx-Rice
2023-06-19gnu: image: Build partitions with only necessary inputs....Efraim Flashner
2023-06-17gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?....Janneke Nieuwenhuizen
2023-06-14system: images: Add unmatched module....Efraim Flashner
2023-06-14gnu: image: Add support for unformatted partitions....Efraim Flashner
2023-06-09linux-container: Adjust to 'modify-services' semantic change....Ludovic Courtès
2023-06-09system: account: Fix default value....Ludovic Courtès
2023-05-21system: pam: Change 'stop' method to return #f....Ludovic Courtès
2023-05-16services: Add default values....Andrew Tropin
2023-05-12system: default-skeletons: Merge search-paths of multiple profiles....宋文武
2023-05-11system: pam: Let PAM extensions add shepherd requirements....Josselin Poiret