From 698e39a251d433e2cd2934586a2dfc5e6582c4f9 Mon Sep 17 00:00:00 2001 From: Philip McGrath Date: Sun, 24 Jul 2022 09:12:55 -0400 Subject: [PATCH] Improve readability of whitespace tests This change fixes the test for `~x` in some environments in which it was previously failing. Related to https://github.com/inukshuk/latex-decode/issues/13 --- features/step_definitions/latex.rb | 5 +++++ features/symbols.feature | 7 ------- features/whitespace.feature | 13 +++++++++++++ 3 files changed, 18 insertions(+), 7 deletions(-) create mode 100644 features/whitespace.feature diff --git a/features/step_definitions/latex.rb b/features/step_definitions/latex.rb index 4b1b595..fca63c0 100644 --- a/features/step_definitions/latex.rb +++ b/features/step_definitions/latex.rb @@ -5,3 +5,8 @@ end Then /^the result should be ('|")(.*)\1$/ do |quote,value| expect(@result).to eq(value) end + +# For whitespace or other characters that are hard to read in source code: +Then /^I should get '([^']*)' \+ U\+(\h{4,}) \+ '([^']*)'$/ do |pre,code,post| + expect(@result).to eq(pre + code.hex.chr(Encoding::UTF_8) + post) +end diff --git a/features/symbols.feature b/features/symbols.feature index 46d9a51..f8a5e84 100644 --- a/features/symbols.feature +++ b/features/symbols.feature @@ -12,10 +12,3 @@ Feature: Decode LaTeX symbol directives | \\uparrow | ↑ | | \\downarrow | ↓ | | \\rightarrow | → | - - Scenarios: Whitespace - | latex | unicode | description | - | x\\,x | x x | small space | - | x~x | x x | non-breaking space | - | ~x |  x | non-breaking space | - diff --git a/features/whitespace.feature b/features/whitespace.feature new file mode 100644 index 0000000..fe5b208 --- /dev/null +++ b/features/whitespace.feature @@ -0,0 +1,13 @@ +Feature: Decode LaTeX whitespace directives + As a hacker who works with LaTeX + I want to be able to decode LaTeX whitespace + + Scenario Outline: LaTeX to Unicode transformation + When I decode the string '' + Then I should get
 + U+ + 
+
+  Scenarios: Whitespace
+    | latex | pre | code | post | description                |
+    | x~x   | 'x' | 00A0 | 'x'  | non-breaking space         |
+    | ~y    | ''  | 00A0 | 'y'  | leading non-breaking space |
+    | z\\,z | 'z' | 2009 | 'z'  | small space                |
-- 
2.32.0

h>Commit message (Expand)Author
2023-11-19linux-boot: Don't create /root before it's used....* gnu/build/linux-boot.scm (boot-system): Postpone the MKDIR of /root.

Change-Id: I589316a5ddf41cada02173ed4dd5b7df09b795e8
Tobias Geerinckx-Rice
2022-09-04linux-boot: Resume from hibernation after pre-boot....* gnu/build/linux-boot.scm (boot-system): Call resume-if-hibernated
after pre-mount.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Jack Hill
2022-03-01initrd: Honor rootfstype and rootflags command-line parameters....* gnu/build/linux-boot.scm (boot-system): Honor rootfstype and rootflags
arguments.  Update doc.  Error out in case there is insufficient information
with regard to the root file system.
Restore the behavior of inferring the root device from the root file system
from the operating system in case the root argument is not provided.
* doc/guix.texi (Initial RAM Disk): Document the new command-line parameters.
Maxim Cournoyer
2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....This is to make it less surprising, given the common convention sets forth by
the kernel Linux command-line parameters.

* gnu/build/linux-boot.scm (boot-system): Rename '--load', '--repl', '--root'
and '--system' to 'gnu.load', 'gnu.repl', 'root' and 'gnu.system',
respectively.  Adjust doc.
(find-long-option): Adjust doc.
* gnu/installer/parted.scm (installer-root-partition-path): Adjust accordingly.
* gnu/system.scm (bootable-kernel-arguments): Add a VERSION argument and
update doc.  Use VERSION to conditionally return old style vs new style initrd
arguments.
(%boot-parameters-version): Increment to 1.
(operating-system-boot-parameters): Adjust doc.
(operating-system-boot-parameters-file): Likewise.
* gnu/system/linux-initrd.scm (raw-initrd, base-initrd): Likewise.
* doc/guix.texi: Adjust doc.
* gnu/build/activation.scm (boot-time-system): Adjust accordingly.
* gnu/build/hurd-boot.scm (boot-hurd-system): Likewise.
* gnu/packages/commencement.scm (%final-inputs-riscv64): Adjust comment.
Maxim Cournoyer
2022-02-17build: linux-boot: Expound docstring of the 'boot-system' procedure....* gnu/build/linux-boot.scm (boot-system): Document the Linux command-line
parameters it understands and split a long string over two lines.
Maxim Cournoyer