Work around two test suite failures on ARM: https://github.com/ruby-concurrency/concurrent-ruby/issues/547 The regexps here assume addresses like "0x1234" but on ARM (32-bit) we get something like "0x-7db1e810" (notice the dash). diff --git a/spec/concurrent/edge/promises_spec.rb b/spec/concurrent/edge/promises_spec.rb index 727210f..149f7cd 100644 --- a/spec/concurrent/edge/promises_spec.rb +++ b/spec/concurrent/edge/promises_spec.rb @@ -371,9 +371,9 @@ describe 'Concurrent::Promises' do four = three.delay.then(&:succ) # meaningful to_s and inspect defined for Future and Promise - expect(head.to_s).to match /<#Concurrent::Promises::Future:0x[\da-f]+ pending>/ + expect(head.to_s).to match /<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/ expect(head.inspect).to( - match(/<#Concurrent::Promises::Future:0x[\da-f]+ pending>/)) + match(/<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/)) # evaluates only up to three, four is left unevaluated expect(three.value!).to eq 3 diff --git a/spec/concurrent/map_spec.rb b/spec/concurrent/map_spec.rb index c4050be..0a9095d 100644 --- a/spec/concurrent/map_spec.rb +++ b/spec/concurrent/map_spec.rb @@ -794,7 +794,7 @@ module Concurrent end it '#inspect' do - regexp = /\A#\Z/i + regexp = /\A#\Z/i expect(Concurrent::Map.new.inspect).to match(regexp) expect((Concurrent::Map.new {}).inspect).to match(regexp) map = Concurrent::Map.new '3211f45f0b741d5dea97de3745804881d7446d34'/>
AgeCommit message (Expand)Author
2019-03-18Correct name and email address for ng0....ng0
2019-03-17gnu: Add editorconfig-vim....Efraim Flashner
2019-03-07gnu: neovim: Let build phase return #T....Ricardo Wurmus
2019-03-07gnu: neovim: Fix #34616....Gábor Boskovits
2019-02-17gnu: neovim: Update to 0.3.4....Danny O'Brien
2019-02-13gnu: vim-airline: Update to 0.10....Efraim Flashner
2018-12-29gnu: vim: Update to 8.1.0644....Efraim Flashner
2018-12-29gnu: vim-full: Fix test suite....Efraim Flashner
2018-12-27gnu: vim: Don't use unstable tarball....Efraim Flashner
2018-12-27gnu: vim: Use https....Efraim Flashner
2018-12-01gnu: vim-fugitive: Update to 2.5....Efraim Flashner
2018-11-30neovim: Update to 0.3.1....Eric Bavier
2018-11-29gnu: vim: Update to 8.1.0551....Marius Bakke
2018-11-12gnu: vifm: Update to 0.10....Efraim Flashner