Add missing include dirs for ROCclr. --- a/amdocl/CMakeLists.txt 2020-12-05 22:05:55.838529158 +0100 +++ b/amdocl/CMakeLists.txt 2020-12-05 22:07:35.677524507 +0100 @@ -23,6 +23,9 @@ include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos) include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos/headers) include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos/headers/opencl2.2) +include_directories(${ROCclr_DIR}/../../../include) +include_directories(${ROCclr_DIR}/../../../include/compiler/lib/include/) +include_directories(${ROCclr_DIR}/../../../include/elf/) if((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR (CMAKE_${COMPILER}_COMPILER_ID MATCHES "Clang")) t type='hidden' name='showmsg' value='1'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/build-aux/update-NEWS.scm
AgeCommit message (Collapse)Author
2021-05-10maint: update-NEWS: Sort packages prior writing to the data file.Maxim Cournoyer
* build-aux/update-NEWS.scm (main): Sort packages.
2021-04-23build-aux: Relax the regexp used to match NEWS sections.Maxim Cournoyer
A number of packages doesn't really make sense in the name of the section to be substituted. This change allows using simply '*** new packages' instead of '*** 1999 new packages', for example, and have the update-NEWS.scm script update it. * build-aux/update-NEWS.scm (write-packages-added) <regexp>: Do not care about leading white space in the name of the section.
2019-05-20maint: update-NEWS: Track "gcc-toolchain", not "gcc".Ludovic Courtès
This is a followup to d78010b81ee6ef4fd8803082e2f401b9e55b44db. * build-aux/update-NEWS.scm (write-packages-updates)[important]: Replace "gcc" by "gcc-toolchain".
2018-12-05maint: update-NEWS: Don't produce full package lists.Ludovic Courtès
The lists of new and upgraded packages in 'NEWS' had become way too long and redundant with what 'guix pull' reports. * build-aux/update-NEWS.scm (write-packages-added): Don't print ADDED. (write-packages-updates)[important, table, latest, noteworthy]: New variables. Print NOTEWORTHY rather than all of UPGRADED. (main): Print PREVIOUS-VERSION and NEW-VERSION.
2018-09-02Add (guix describe) and use it to initialize '%package-search-path'.Ludovic Courtès
* guix/describe.scm: New file. * Makefile.am (MODULES): Add it. * gnu/packages.scm (%default-package-module-path): New variable. (%package-module-path): Honor 'package-path-entries'. * build-aux/update-NEWS.scm (main): Use %DEFAULT-PACKAGE-MODULE-PATH instead of (last (%package-module-path)).