This patch adds a header file that is present in the ripperx git and needed for inclusion, but missing in the distribution tarball. diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h --- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100 +++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200 @@ -0,0 +1,39 @@ +#ifndef gtk_cpp_workaround_h +#define gtk_cpp_workaround_h +#ifdef __cplusplus +//proto is wrong, override here for C++ +namespace +{ + +inline void gtk_table_attach (GtkTable *table, + GtkWidget *child, + guint left_attach, + guint right_attach, + guint top_attach, + guint bottom_attach, + //GtkAttachOptions xoptions, + //GtkAttachOptions yoptions, + guint xoptions, guint yoptions, + guint xpadding, + guint ypadding + ) +{ + gtk_table_attach(table, + child, + left_attach, + right_attach, + top_attach, + bottom_attach, + (GtkAttachOptions)xoptions, + (GtkAttachOptions)yoptions, + xpadding, + ypadding + ); + + }; + + +} + +#endif +#endif '>logtreecommitdiff
path: root/tests/pack.scm
AgeCommit message (Expand)Author
2019-12-26gnu: Remove squashfs-tools-next....Ricardo Wurmus
2019-08-27pack: Create /tmp in Docker images....Ludovic Courtès
2019-03-24tests: Adjust 'guix pack -f squashfs' test....Ludovic Courtès
2018-11-06store-copy: Canonicalize the mtime and permissions of the store copy....Ludovic Courtès
2018-11-06pack: Add test for 'self-contained-tarball' with localstatedir....Ludovic Courtès
2018-11-06pack: Squashfs backend now honors '--localstatedir'....Ludovic Courtès
2018-11-06pack: Docker backend now honors '--localstatedir'....Ludovic Courtès
2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès
2018-10-28tests: Fix typo....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-09-18tests: Skip 'self-contained-tarball' test unconditionally....Ludovic Courtès
2018-06-01pack: Adjust test to expect relative symlinks....Ludovic Courtès
2018-06-01tests: Fix arguments in pack test....Ricardo Wurmus
2017-03-22tests: Skip 'guix pack' test when networking is unavailable....Ludovic Courtès
2017-03-17pack: Move absolute file name to <compressor>....Ludovic Courtès
2017-03-14pack: Add unit test....Ludovic Courtès